Bug 88195 - [gen4] GPU hang in Chrome
Summary: [gen4] GPU hang in Chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-08 08:30 UTC by Alex Hirzel
Modified: 2015-04-30 18:15 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (845.12 KB, text/plain)
2015-01-08 08:30 UTC, Alex Hirzel
Details
dmesg output asking me to file bug (65.59 KB, text/plain)
2015-01-08 08:30 UTC, Alex Hirzel
Details
software versions (output of pacman -Q) (22.91 KB, text/plain)
2015-01-08 08:30 UTC, Alex Hirzel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Hirzel 2015-01-08 08:30:11 UTC
Created attachment 111941 [details]
GPU crash dump

Experienced a crash when using Chromium. Running Arch Linux and my software versions are attached (versions.txt).

I saw the log in dmesg (attached, dmesg.txt) which asked me to file a bug. I have attached the crash dump (error.txt).

I would ordinarily not be motivated to file this report, but dmesg asked me to do it! I do not have steps to reproduce, and this crash occurred only once. If there is a PKGBUILD I would be willing to run a newer version for testing purposes.
Comment 1 Alex Hirzel 2015-01-08 08:30:40 UTC
Created attachment 111942 [details]
dmesg output asking me to file bug
Comment 2 Alex Hirzel 2015-01-08 08:30:59 UTC
Created attachment 111943 [details]
software versions (output of pacman -Q)
Comment 3 Matt Turner 2015-03-06 23:25:56 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x > 3. Please try upgrading to >10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 4 Matt Turner 2015-04-30 18:15:07 UTC
No reply. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.