Bug 88247 - Commit 4457345 causes 2 DrawElements test regressions
Summary: Commit 4457345 causes 2 DrawElements test regressions
Status: RESOLVED DUPLICATE of bug 87887
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Matt Turner
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-09 18:03 UTC by Mike Mason
Modified: 2015-01-19 15:07 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Mason 2015-01-09 18:03:29 UTC
Environment:
Mesa: (master 934e41c0b31cffa4efc08f61cff2389e3149b3f3)
Ubuntu 14.04

Commit 4457345 "i965/vec4: Add pass to gather constants into a vector-float MOV" caused regressions in the following 2 DrawElements tests:

dEQP-GLES3.functional.shaders.texture_functions.texturegradoffset.sampler2dshadow_vertex
dEQP-GLES3.functional.shaders.texture_functions.texturegradoffset.sampler2darrayshadow_vertex


Analysis:

Bisect shows 44573458bdc52acc304fb75d6df502312b8e149c is the first bad commit.

Author: Matt Turner <mattst88@gmail.com>
Date:   Sat Dec 20 11:50:31 2014 -0800

    i965/vec4: Add pass to gather constants into a vector-float MOV.
    
    Currently only handles consecutive instructions with the same
    destination that collectively write all channels.
    
    total instructions in shared programs: 5879798 -> 5869011 (-0.18%)
    instructions in affected programs:     465236 -> 454449 (-2.32%)
    
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>


Steps to reproduce:

# ./deqp-gles3 --deqp-case=dEQP-GLES3.functional.shaders.texture_functions.texturegradoffset.sampler2dshadow_vertex
# ./deqp-gles3 --deqp-case=dEQP-GLES3.functional.shaders.texture_functions.texturegradoffset.sampler2darrayshadow_vertex
Comment 1 Matt Turner 2015-01-12 23:13:09 UTC
Please try the patch attached in bug 87887.
Comment 2 Matt Turner 2015-01-15 18:12:43 UTC
Committed

commit 41d9f232b6a7f53086b9c428cca30e45905abd48
Author: Matt Turner <mattst88@gmail.com>
Date:   Mon Jan 12 10:48:04 2015 -0800

    i965/vec4: Make sure that imm writes are to registers in the same file.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=87887

which I suspect fixes it.

*** This bug has been marked as a duplicate of bug 87887 ***
Comment 3 Mike Mason 2015-01-19 15:07:15 UTC
Verified that the two failing DrawElements tests now pass with this patch.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.