Bug 8827 - [64-bit] exiting the last app crashes nude xserver
Summary: [64-bit] exiting the last app crashes nude xserver
Status: CLOSED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xorg-7.2
  Show dependency treegraph
 
Reported: 2006-10-30 01:35 UTC by Shuang He
Modified: 2006-11-13 00:40 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
X conf file (2.76 KB, text/plain)
2006-10-30 01:35 UTC, Shuang He
no flags Details
X server log (74.07 KB, text/plain)
2006-10-30 01:36 UTC, Shuang He
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2006-10-30 01:35:34 UTC
--Architecture(ia32,ia32e,compatiblity): ia32e
--2D driver: git(fbb376bd1a4daad4c86e349df98438989ce173f1)
--Xorg: 7.1
--Mesa: CVS tip
--OS: FC5
--Kernel: 2.6.19-rc3

Note: this issue happens on 965g, 945g, and 915gv platforms.

1.Start a X server
2.run the xterm
3.and when exit from xterm
4.the X server will crash with following output:
Backtrace:
0: X(xf86SigHandler+0x6d) [0x4811cd]
1: /lib64/libc.so.6 [0x3cb902f7c0]
2: X [0x4f4770]
3: X [0x44b9af]
4: X(InitClientPrivates+0xb0) [0x441d20]
5: X(main+0x2b4) [0x430b84]
6: /lib64/libc.so.6(__libc_start_main+0xf4) [0x3cb901d084]
7: X(FontFileCompleteXLFD+0xa1) [0x430029]

Fatal server error:
Caught signal 11.  Server aborting
Comment 1 Shuang He 2006-10-30 01:35:58 UTC
Created attachment 7584 [details]
X conf file
Comment 2 Shuang He 2006-10-30 01:36:18 UTC
Created attachment 7585 [details]
X server log
Comment 3 Alan Hourihane 2006-10-30 01:40:09 UTC
Does this happen with the vesa driver ?
Comment 4 Gordon Jin 2006-10-30 17:42:28 UTC
Yes, we just tested with vesa, and it also crashed.
Comment 5 Alan Hourihane 2006-10-31 00:54:01 UTC
Not an i810 driver bug then. Reassigning to DDX.
Comment 6 Gordon Jin 2006-11-02 01:45:58 UTC
anyone see this issue?
Comment 7 Eamon Walsh 2006-11-07 13:04:11 UTC
Sorry about this.  This should be fixed now.  See #8875.

*** This bug has been marked as a duplicate of 8875 ***
Comment 8 Gordon Jin 2006-11-07 17:33:47 UTC
verified, thanks.
Comment 9 Gordon Jin 2006-11-09 20:59:01 UTC
I'm reopening as this issue shows again, though it was ok 3 days ago.
Comment 10 Gordon Jin 2006-11-09 20:59:55 UTC
reopening.
Comment 11 Gordon Jin 2006-11-13 00:40:25 UTC
It goes away with the latest xserver.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.