Bug 88463 - Black screen on "Unlocking the disk" screen
Summary: Black screen on "Unlocking the disk" screen
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-15 14:52 UTC by Roman
Modified: 2015-01-16 13:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman 2015-01-15 14:52:51 UTC
Hardware: Dell Vostro 1500 (Core 2 Duo T7250, GeForce 8400 GS 128 MB and 8600 GT 256 MB, I upgraded GPU and both are affected).

Software: Ubuntu 14.04 x64 and 14.10 x64 with Nouveau driver. Whole HDD is encrypted using native Ubuntu feature (with LVM), which was selected and configured during standard OS installation process.

Problem description: When I turn PC on I can see BIOS info, after that I see purple screen for couple of seconds, then black screen (there should be "Unlocking the disk" screen). But when I type in the password and press Enter PC starts. It starts with black screen until Ubuntu login screen appears. From Ubuntu login screen I log in as usual and everything is ok.

P.S. After I turn off PC while black screen (where should be "Unlocking the disk" screen) with long press of power button - when I turn it on again GRUB starts and "Unlocking the disk" screen appears (no black screen and everything is good).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.