Bug 8874 - xorg crashes when switching virtual console with mga g550
Summary: xorg crashes when switching virtual console with mga g550
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-03 09:32 UTC by markus gapp
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markus gapp 2006-11-03 09:32:45 UTC
hi,

on an amd64 with 64 bit gentoo linux, kernel 2.6.18 smp, xorg 7.1, mesa 6.5.1, 
libdrm 2.2.0 and mga dirver 1.4.4 X freezes when switching back to a running 
instance from another virtual console.

/var/log messages gets filled with
[drm:mga_dma_reset] *ERROR* mga_dma_reset called without lock held
repeatedly, xorg.log says:
(EE) MGA(0): [dri] Idle timed out, resetting engine...

thank you

markus
Comment 1 Tilman Sauerbeck 2006-11-03 10:25:21 UTC
Does it lock up when you switch from a virtual console to X, or when you switch
from X to a virtual console?

Does using an older version of the MGA driver (1.4.3 or 1.4.2) fix it?
Comment 2 markus gapp 2006-11-03 14:58:01 UTC
I don't actually know when the error is happening, however the log messages 
begin to appear as soon as i try to switch back from a text virtual console to 
a previously functioning X which appears to be frozen. the screen contents is 
grabled in the upper third, the other parts show a static picture of the 
desktop.

A second X instance doesn't show up at all but freezes the whole system making 
a reboot necessary. Could not produce error messages in the logs for this case 
yet.

yes it also happens with version 1.4.2 and 1.4.3 (and 1.4.4) of the mga driver.

thanx, markus
Comment 3 Jesus Rodriguez 2006-11-16 23:36:16 UTC
Same thing here, under the following circumstances (BTW, I'm using FBDev):

1) Switching to VC and back again to X
2) Starting beryl/compiz (but NOT xcompmgr)
3) Sometimes, starting glxgears
Comment 4 Jesus Rodriguez 2006-11-17 05:52:00 UTC
Edit comment #3: My card is a G200
Comment 5 Michal Suchanek 2011-09-27 07:41:41 UTC
isn't this bug 8191 ?
Comment 6 Martin Peres 2019-10-14 13:20:02 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.