Bug 88792 - [BDW/BSW Bisected]Piglit spec_ARB_pixel_buffer_object_pbo-read-argb8888 fails
Summary: [BDW/BSW Bisected]Piglit spec_ARB_pixel_buffer_object_pbo-read-argb8888 fails
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-26 05:51 UTC by lu hua
Modified: 2015-01-30 03:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2015-01-26 05:51:08 UTC
System Environment:
--------------------------
Platform: BDW
Libdrm:		(master)libdrm-2.4.59-2-g0c5aaeef51233aec89ee1f43f03d457f278f8fa0
Mesa:		(master)0aa31bf9c37e11c041f951342f38c38907c620ff
Xserver:		(master)xorg-server-1.16.99.902
Xf86_video_intel:		(master)2.99.917-50-ged19b160089640c2e1167332b00ffe1e569a48dc
Libva:		(master)f9741725839ea144e9a6a1827f74503ee39946c3
Libva_intel_driver:		(master)3d16cf07b6b65b9bd5c2dd855d97558264a12e79
Kernel:   (drm-intel-nightly)67e9eb08a3b967b1ac6b7ec4588a93a2cb030cae

Bug detailed description:
---------------------------
It fails on BDW with mesa master branch, works well on 10.4 branch.
Following  cases also fail with the same bisect commit.
spec_EXT_texture_compression_s3tc_getteximage-targets_S3TC_2D_ARRAY 
spec_EXT_texture_compression_s3tc_getteximage-targets_S3TC_CUBE   
spec_EXT_texture_compression_s3tc_getteximage-targets_S3TC_CUBE_ARRAY   
ES3-CTS.gtf.GL3Tests.pixel_buffer_object.pixel_buffer_object_texture_read
ES3-CTS.gtf.GL3Tests.pixel_buffer_object.pixel_buffer_object_texture_pixelstore

Bisect shows: ef0499af255ecd3a9abbd350ace5e00a744adc0 is the first bad commit.
commit ef0499af255ecd3a9abbd350ace5e00a744adc00
Author:     Jason Ekstrand <jason.ekstrand@intel.com>
AuthorDate: Mon Jan 12 16:20:27 2015 -0800
Commit:     Jason Ekstrand <jason.ekstrand@intel.com>
CommitDate: Thu Jan 22 10:36:25 2015 -0800

    i965/pixel_read: Use meta_pbo_GetTexSubImage for PBO ReadPixels

    Since the meta path can do strictly more than the blitter path, we just
    remove the blitter path entirely.

    Reviewed-by: Neil Roberts <neil@linux.intel.com>


output:
libGL: screen 0 does not appear to be DRI3 capable
libGL: pci id for fd 4: 8086:1616, driver i965
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
Probe color at (10,10)
  Expected: 0x0000ff00
  Observed: 0x00ff0000
Probe color at (10,10)
  Expected: 0x00ff0000
  Observed: 0x00000000
PIGLIT: {"result": "fail" }

Reproduce steps:
-------------------------
1. xinit
2. bin/pbo-read-argb8888 -auto
Comment 1 lu hua 2015-01-26 06:19:30 UTC
ES3-CTS.gtf.GL3Tests.pixel_buffer_object.pixel_buffer_object_texture_pixelstore also fails with the same bisect commit.
Comment 2 lu hua 2015-01-30 03:00:43 UTC
It works well on the latest Mesa master branch.
Comment 3 lu hua 2015-01-30 03:00:55 UTC
Verified.Fixed.


bug/show.html.tmpl processed on Feb 21, 2017 at 19:04:56.
(provided by the Example extension).