Bug 88899 - libinput crashes Xorg startup on VirtualBox
Summary: libinput crashes Xorg startup on VirtualBox
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-01 15:11 UTC by Dario Freddi
Modified: 2015-02-04 23:59 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (10.82 KB, text/plain)
2015-02-01 15:11 UTC, Dario Freddi
Details
evemu-describe on Virtualbox Mouse Integration (1.83 KB, text/plain)
2015-02-02 12:39 UTC, Dario Freddi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dario Freddi 2015-02-01 15:11:29 UTC
Created attachment 113020 [details]
Xorg log
Comment 1 Dario Freddi 2015-02-01 15:12:34 UTC
When running Xorg with libinput on VirtualBox, the server crashes. This behavior is not reproducible with the evdev driver, which works as expected instead.
Comment 2 Peter Hutterer 2015-02-01 21:21:14 UTC
record the virtual box input devices with evemu-describe please and attach the output here. Looks like libinput isn't happy with one of them.
Comment 3 Dario Freddi 2015-02-02 12:39:36 UTC
Created attachment 113051 [details]
evemu-describe on Virtualbox Mouse Integration

Attached evemu-describe for the device
Comment 4 Peter Hutterer 2015-02-03 01:07:46 UTC
the quick fix for this is to run a s/malloc/zalloc/ across libinput. The longer fix is this patch series here:
http://lists.freedesktop.org/archives/wayland-devel/2015-February/019735.html
Comment 5 Peter Hutterer 2015-02-04 21:16:32 UTC
Fixed with the three patches leading up to

commit 154b3cf74941c26cdf77a24136c273ee7d9f6e65
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Tue Feb 3 09:37:53 2015 +1000

    Don't init pointer acceleration on absolute devices
Comment 6 Dario Freddi 2015-02-04 23:59:36 UTC
Thanks for the quick resolution!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.