Bug 88925 - GPU lockup in XCOM with R270X
Summary: GPU lockup in XCOM with R270X
Status: RESOLVED DUPLICATE of bug 80419
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-02 21:43 UTC by Daniel Exner
Modified: 2018-08-31 06:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
First stall (3.22 KB, text/plain)
2015-02-02 21:43 UTC, Daniel Exner
Details
2. Stall (3.22 KB, text/plain)
2015-02-02 21:43 UTC, Daniel Exner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Exner 2015-02-02 21:43:10 UTC
Created attachment 113074 [details]
First stall

I'm seeing a constant number of GPU lockups in this game. About 5-10 Minutes in Game right after anything happens on screen that looks like it may need some more GPU power it freezes.

Hardware:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Pitcairn (prog-if 00 [VGA controller])
        Subsystem: Micro-Star International Co., Ltd. Device 3036
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 34
        Region 0: Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at fea00000 (64-bit, non-prefetchable) [size=256K]
        Region 4: I/O ports at e000 [size=256]
        Expansion ROM at fea40000 [disabled] [size=128K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1+,D2+,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 8GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis-, LTR-, OBFF Not Supported
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                LnkCtl2: Target Link Speed: 8GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee00000  Data: 0000
        Capabilities: [100 v1] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150 v2] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [270 v1] #19
        Capabilities: [2b0 v1] Address Translation Service (ATS)
                ATSCap: Invalidate Queue Depth: 00
                ATSCtl: Enable+, Smallest Translation Unit: 00
        Capabilities: [2c0 v1] #13
        Capabilities: [2d0 v1] #1b
        Kernel driver in use: radeon

Software:
* Kernel 3.19.0-rc7-13532-g1b7a4a0
* xorg-server 1.16.3
* llvm SVN 227800
* Mesa 10.5.0-devel (git-af8fd69)
* xf86-video-ati 7.5.0
Comment 1 Daniel Exner 2015-02-02 21:43:42 UTC
Created attachment 113075 [details]
2. Stall
Comment 2 Michel Dänzer 2015-02-03 03:55:11 UTC
Sounds like bug 80419.
Comment 3 Daniel Exner 2015-02-03 11:34:51 UTC
(In reply to Michel Dänzer from comment #2)
> Sounds like bug 80419.

Possible. But the game worked fine until about start of the year. I think I may still have the packaged versions of llvm and mesa from then and perhaps I can confirm this.

I strongly suspect LLVM being the culprit here.
Comment 4 Daniel Exner 2015-02-03 22:15:57 UTC
(In reply to dex+fdobugzilla from comment #3)
> (In reply to Michel Dänzer from comment #2)
> > Sounds like bug 80419.
> 
> But the game worked fine until about start of the year. I think I
> may still have the packaged versions of llvm and mesa from then and perhaps
> I can confirm this.

With:
* Mesa 10.5.0-devel (git-6171131)
* LLVM 225080
* Kernel: 3.19.0-rc7-13532-g1b7a4a0 (same)

No lockups

So this is either a LLVM or Mesa Issue.

I will now compile latest Mesa with LLVM 225080 and see if that works.

Given that this is hardly a DRI/Radeon issue.. where should I move this bug?
Comment 5 Daniel Exner 2015-02-04 22:34:05 UTC
(In reply to dex+fdobugzilla from comment #4)
> So this is either a LLVM or Mesa Issue.
> 
> I will now compile latest Mesa with LLVM 225080 and see if that works.

I tried LLVm 22508 with Mesa Git(2335153) with Changeset a8ef880a1b38cbcfc26e9f829338739d16cece99 reverted:

No Lockups

I guess its LLVM then. I continue with LLVM bisecting
Comment 6 Marek Olšák 2015-08-02 12:49:47 UTC
Is this a duplicate of bug 80419 ?
Comment 7 Timothy Arceri 2018-08-31 06:20:22 UTC
Assuming duplicate as there was no reply and no further reports of the issue.

*** This bug has been marked as a duplicate of bug 80419 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.