Bug 89061 - Some parts of the document aren't printed
Summary: Some parts of the document aren't printed
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-10 10:29 UTC by Geert Janssens
Modified: 2018-08-21 11:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
File to illustrate the bug (130.86 KB, application/octet-string)
2015-02-10 10:29 UTC, Geert Janssens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geert Janssens 2015-02-10 10:29:00 UTC
Attached you will find an invoice I receive monthly in pdf format. This
document displays fine in okular. If I print it (or look at the print preview
for that matter) I find that the text below "Facturatieadres" is hidden except
for one character and hence not printed properly.

This happens with every invoice I receive from this vendor.

I can print this document just fine with evince on the same machine.

Reproducible: Always

Steps to Reproduce:
1. Open the attached document
2. Open print preview in okular or print it

Actual Results:  
The text below "Facturatieadres" is not visible except for one character. The
same when you effectively print the document.

Expected Results:  
The address would be printeld completely.

I had first reported this bug against okular [1], but I was told this is a bug in poppler and I should report it here.

[1] https://bugs.kde.org/show_bug.cgi?id=343996
Comment 1 Geert Janssens 2015-02-10 10:29:36 UTC
Created attachment 113311 [details]
File to illustrate the bug
Comment 2 Jakub Alba 2016-08-02 18:45:18 UTC
I've tested it with evince 3.20. It doesn't happen for me. Does it still happen for you?
Comment 3 Geert Janssens 2016-08-03 07:45:08 UTC
Thanks for your feedback. However as said in my original report above, it has always worked fine in evince.

I have the issue when printing via okular and the okular developers forwarded me here as they claim it's a poppler bug. I have no idea whether evince uses poppler or not.

Current okular/poppler on my Fedora 23 machine still shows this erroneous behaviour.

okular-15.12.3-1.fc23.x86_64
poppler-0.34.0-2.fc23.x86_64
Comment 4 Jakub Alba 2016-08-03 08:25:02 UTC
Evince does use poppler. I've installed Okular and it seems that it's a poppler bug, because even when I use poppler from the git master tree, the problem remains. Nothing like that happens in evince. So I'd day it's an Okular, not a poppler bug.
Comment 5 Jakub Alba 2016-08-03 08:27:02 UTC
Should be "it seems that it's an Okular bug". Sorry, little sleep lately.
Comment 6 Albert Astals Cid 2016-08-03 08:40:17 UTC
Jakub, you're wrong, Okular does use poppler for printing, try pdftops and you'll see the bug.
Comment 7 Adrian Johnson 2016-08-06 05:20:33 UTC
(In reply to Jakub Kucharski from comment #4)
> Evince does use poppler. I've installed Okular and it seems that it's a
> poppler bug, because even when I use poppler from the git master tree, the
> problem remains. Nothing like that happens in evince. So I'd day it's an
> Okular, not a poppler bug.

Evince uses CairoOutputDev for printing. Okular uses PSOutputDev.

Testing with pdftocairo (both -ps and -pdf) works. Testing with pdftops fails with the same results as the bug report.

We should have a "ps backend" component added to bugzilla to make it easier to find related PSOutputDev bugs.
Comment 8 Albert Astals Cid 2016-08-07 22:25:39 UTC
Adrian, if you know how to request one more component, please do so.
Comment 9 GitLab Migration User 2018-08-21 11:09:52 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/542.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.