Bug 89178 - Chrome window doesn't receives clicks when using weston + xwayland
Summary: Chrome window doesn't receives clicks when using weston + xwayland
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-17 01:16 UTC by Henry
Modified: 2015-04-07 06:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henry 2015-02-17 01:16:04 UTC
Chrome is installed in weston+ xwayland environment, but there is no mouse response.
I couldn't click any button with mouse, but keyboard works well.
Firefox don't has this problem, but there is no maximum/minimum button on the windows.

I tried to update weston/wyaland to 1.7.0, but stil doesn't work.

similar issue:
https://code.google.com/p/chromium/issues/detail?id=398595
Comment 1 Henry 2015-02-23 13:45:46 UTC
it is bug in weston. Chrom works well in another compositor: loliwm
https://github.com/Cloudef/loliwm
Comment 2 Pekka Paalanen 2015-03-27 11:59:44 UTC
Could this have been fixed with
http://cgit.freedesktop.org/wayland/weston/commit/?id=d19e9b0e424125230107b4c8082a90971678dcbf
by any chance?
Comment 3 yashax 2015-04-06 16:19:10 UTC
(In reply to Pekka Paalanen from comment #2)
> Could this have been fixed with
> http://cgit.freedesktop.org/wayland/weston/commit/
> ?id=d19e9b0e424125230107b4c8082a90971678dcbf
> by any chance?

Yes, the issue is gone with current weston git.
Comment 4 Pekka Paalanen 2015-04-07 06:55:43 UTC
Thanks, let's mark this as fixed then.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.