Bug 89316 - [HSW, regression, bisected] i965/tex_image: Use meta for instead of the blitter PBO TexImage and GetTexImage (779923194c65ed3)
Summary: [HSW, regression, bisected] i965/tex_image: Use meta for instead of the blitt...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-25 07:47 UTC by Samuel Iglesias Gonsálvez
Modified: 2015-02-27 19:31 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Iglesias Gonsálvez 2015-02-25 07:47:18 UTC
Steps to reproduce:

$ cd <deqp-home>
$ cd modules/gles3
$ ./deqp-gles3 -n dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32f_2d_array

The complete list of affected dEQP tests is:

dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba32ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba16ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.srgb8_alpha8_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.srgb8_alpha8_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb10_a2_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb10_a2_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb10_a2ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb10_a2ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgba8_snorm_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb565_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rgb565_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r11f_g11f_b10f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r11f_g11f_b10f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg32ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg16ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.rg8_snorm_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r32ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16f_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16f_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r16ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8i_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8i_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8ui_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8ui_3d
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.teximage3d_pbo.r8_snorm_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba32ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba16ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.srgb8_alpha8_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.srgb8_alpha8_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb10_a2_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb10_a2_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb10_a2ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb10_a2ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgba8_snorm_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb565_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rgb565_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r11f_g11f_b10f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r11f_g11f_b10f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg32ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg16ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.rg8_snorm_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r32ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16f_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16f_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r16ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8i_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8i_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8ui_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8ui_3d
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8_snorm_2d_array
dEQP-GLES3.functional.texture.specification.texsubimage3d_pbo.r8_snorm_3d

The commit that introduced this regression is:

commit 779923194c65ed3a588d3503cc5d53e1945ada0f
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Mon Jan 12 16:21:17 2015 -0800

    i965/tex_image: Use meta for instead of the blitter PBO TexImage and GetTexImage
    
    Reviewed-by: Neil Roberts <neil@linux.intel.com>
Comment 1 Jason Ekstrand 2015-02-25 15:49:38 UTC
That's what I figured was wrong.  Laura pushed a couple of passes yesterday that should have fixed this.  Is it still broken on master?
Comment 2 Samuel Iglesias Gonsálvez 2015-02-25 16:16:25 UTC
It is fixed in master. I'm going to close this bug.

Thanks!
Comment 3 Ian Romanick 2015-02-25 16:58:33 UTC
It looks like this commit is also on the 10.5 branch.  Were the fixes marked for stable?  If not, please send a note to mesa-stable so that Emil will cherry pick them.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.