Bug 89347 - TypeError: __init__() got an unexpected keyword argument 'future_imports'
Summary: TypeError: __init__() got an unexpected keyword argument 'future_imports'
Status: RESOLVED FIXED
Alias: None
Product: piglit
Classification: Unclassified
Component: infrastructure (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium blocker
Assignee: Dylan Baker
QA Contact: Piglit Mailing List
URL:
Whiteboard:
Keywords: regression
: 89349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-26 23:45 UTC by Vinson Lee
Modified: 2015-02-27 07:43 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2015-02-26 23:45:16 UTC
piglit: 6cea8c1bdfdb518c83b70bea3d34c7acfa821024 (master)


Scanning dependencies of target gen-gl-tests
[ 98%] Generating builtin_packing_tests.list
Traceback (most recent call last):
  File "piglit/generated_tests/gen_builtin_packing_tests.py", line 48, in <module>
    TEMPLATES = template_dir(os.path.basename(os.path.splitext(__file__)[0]))
  File "piglit/generated_tests/templates/__init__.py", line 86, in template_dir
    output_encoding='utf-8')
TypeError: __init__() got an unexpected keyword argument 'future_imports'


This might be a Mako version related.

>>> import mako
>>> mako.__version__
'0.7.3'
Comment 1 Vinson Lee 2015-02-27 05:34:07 UTC
commit cd17a23e3c6196dbb68be4704e6904ccc821b030
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Thu Feb 26 16:15:00 2015 -0800

    cmake: Require mako >= 0.8.0.
    
    future_imports was added in Mako 0.8.0.
    
    http://docs.makotemplates.org/en/latest/changelog.html#change-0.8.0
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89347
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Dylan Baker <baker.dylan.c@gmail.com>
Comment 2 Vinson Lee 2015-02-27 07:43:53 UTC
*** Bug 89349 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.