Bug 89487 - [ivo] Freeze after standby
Summary: [ivo] Freeze after standby
Status: NEEDINFO
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-08 17:04 UTC by Kirill Müller
Modified: 2016-07-05 12:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Script in /usr/lib/pm-utils/sleep.d (needs to be executable) to kill ivo before suspend (280 bytes, text/plain)
2015-03-08 17:04 UTC, Kirill Müller
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Müller 2015-03-08 17:04:01 UTC
Created attachment 114135 [details]
Script in /usr/lib/pm-utils/sleep.d (needs to be executable) to kill ivo before suspend

Sorry for potential double-posting.

I'm experiencing occasional freezes on my T430 after waking from suspend/standby when intel-virtual-output was active when I initiated suspend. Only REISUB seems to help.

To work around this issue, I have created a script in /usr/lib/pm-utils/sleep.d that kills ivo and waits for two seconds before actually performing suspension (attached). I was wondering if a nicer solution exists, or if I can help troubleshooting the underlying cause of the problem. (Having to restart ivo after resume is much less troublesome than having to reboot the system, but of course it would be best if it "just worked" -- like the rest of the very helpful tool.)
Comment 1 Chris Wilson 2015-03-08 19:42:36 UTC
Hmm, I need whatever info you can get from the hang. Obviously, it is more likely to be the probing and modesetting after resume that causes the hang.
Comment 2 Kirill Müller 2015-03-08 19:53:59 UTC
I don't have experience in troubleshooting hangs and freezes, but if you could tell me what to look out for (or point me at good instructions) I'll be glad to help.

Maybe it hasn't anything to do with ivo, but with the discrete graphics that has problems with resuming. I'll try a few suspend/resume runs with "optirun sleep 10000" active to double-check this.
Comment 3 Chris Wilson 2015-03-08 20:01:00 UTC
First check things like /var/log/syslog (/var/log/messages etc) to see if anything made it to disk before the hang. I would recommend you try setting up netconsole as that sends all the kernel messages to a second machine, which is very useful in these hard hangs. I would also enable as much kernel debugging as you can in the hope that the hang is made more graceful (i.e. not take the whole machine without trace).
Comment 4 Kirill Müller 2015-03-08 20:20:43 UTC
When I tried suspend while running "optirun sleep 10000" (without ivo), on the fourth occasion or so the following happened on resume:

- A black screen with a mouse cursor appeared on the primary (laptop) display, but the cursor didn't respond to mouse movements
- After less than a minute, I was welcomed with a login screen; the login screen was shown on the external displays, the laptop display was still frozen
- After login, "cat /proc/acpi/bbswitch" shows "ON", but my "optirun" process is gone

I guess this has at least partly to do with the nvidia driver.

I'll be collecting syslogs. I really hope the relevant information makes it to the disks...


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.