Bug 89489 - [gen4] GPU hang in chrome
Summary: [gen4] GPU hang in chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-08 18:57 UTC by astronouth7303
Modified: 2015-04-30 18:16 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (848.11 KB, text/plain)
2015-03-08 18:57 UTC, astronouth7303
Details

Note You need to log in before you can comment on or make changes to this bug.
Description astronouth7303 2015-03-08 18:57:14 UTC
Created attachment 114137 [details]
/sys/class/drm/card0/error

Running Debian testing. Linux zoe 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt4-3 (2015-02-03) x86_64 GNU/Linux

[ 2861.804989] [drm] GPU HANG: ecode 0:0x8644f8fe, in chrome [1298], reason: Ring hung, action: reset
[ 2861.804991] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 2861.804992] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 2861.804994] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 2861.804995] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 2861.804996] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 2861.805111] [drm:i915_reset] *ERROR* Failed to reset chip: -19
[ 2871.556971] totem[2219]: segfault at 1f8 ip 00007ffa4ed42def sp 00007fffa1abbc20 error 4 in i965_dri.so[7ffa4e9ed000+51e000]

This crash can be reliably reproduced by navigating to feedly.com in Google Chrome and hovering over the side bar.
Comment 1 astronouth7303 2015-03-08 19:12:02 UTC
I'm using an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller
Comment 2 Matt Turner 2015-03-08 20:38:57 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x >= 3. Please try upgrading to >=10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 3 Matt Turner 2015-04-30 18:16:37 UTC
No reply. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.