Bug 89498 - [IGT]igt/gem_render_tiled_blits/swap-thrash time out
Summary: [IGT]igt/gem_render_tiled_blits/swap-thrash time out
Status: CLOSED DUPLICATE of bug 91454
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 103083 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-09 08:20 UTC by Ding Heng
Modified: 2018-02-13 16:27 UTC (History)
4 users (show)

See Also:
i915 platform: ALL
i915 features: GEM/Other


Attachments
dmesg (125.44 KB, text/plain)
2015-03-09 08:20 UTC, Ding Heng
no flags Details
HW-ULT_dmesg.txt (123.07 KB, text/plain)
2015-08-12 01:28 UTC, Humberto Israel Perez Rodriguez
no flags Details
HW-ULT_2_dmesg.txt (123.12 KB, text/plain)
2015-08-12 05:12 UTC, Humberto Israel Perez Rodriguez
no flags Details
dmesg log (124.96 KB, text/plain)
2015-08-14 18:26 UTC, Jairo Miramontes
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ding Heng 2015-03-09 08:20:38 UTC
Created attachment 114149 [details]
dmesg

==System Environment==
--------------------------
Non-working platforms: SNB
Regression :No, I didn't find find a good commit.

==kernel==
--------------------------
origin/drm-intel-nightly: c2f6e584b215dd0d7e5a8a02716a89e985366ec0(2015-03-08) 


==Bug detailed description==
-----------------------------

[root@x-hnr9 tests]# ./gem_render_tiled_blits --run-subtest swap-thrash
IGT-Version: 1.9-g50158de (x86_64) (Linux: 4.0.0-rc2_drm-intel-nightly_c2f6e5_20150307+ x86_64)
Using a snoop linear buffer for comparisons
Verifying initialisation...
Cyclic blits, forward...
Killed
[root@x-hnr9 tests]# echo $?
137

==Reproduce steps==
---------------------------- 
1. ./gem_render_tiled_blits --run-subtest swap-thrash
Comment 1 lu hua 2015-03-12 03:16:38 UTC
gem_render_tiled_blits/swap-thrash also has this issue.
Comment 2 Chris Wilson 2015-03-12 08:11:46 UTC
The output of "./gem_render_tiled_blits --debug --run-subtest swap-thrash" would be useful.
Comment 3 Ding Heng 2015-03-12 08:49:13 UTC
(In reply to Chris Wilson from comment #2)
> The output of "./gem_render_tiled_blits --debug --run-subtest swap-thrash"
> would be useful.

./gem_render_tiled_blits --debug --run-subtest swap-thrash IGT-Version: 1.9-g07be8fe (x86_64) (Linux: 4.0.0-rc3_drm-intel-nightly_f72a97_20150312+ x86_64)
(gem_render_tiled_blits:4808) drmtest-DEBUG: Test requirement passed: fd >= 0
Test requirement passed: !igt_run_in_simulation()
Starting subtest: swap-thrash
Test requirement passed: swap_mb > 0
Checking 4602 surfaces of size 1048576 bytes (total 4827906048) against RAM + swap
Test requirement passed: !(total <= required)
Test requirement passed: !igt_run_in_simulation()
Test requirement passed: render_copy
Test requirement passed: ret == 0
Using a snoop linear buffer for comparisons
Verifying initialisation...
Comment 4 Humberto Israel Perez Rodriguez 2015-08-12 01:26:40 UTC
With the latest test environment and HSW-ULT platform this test keeps failing. 
Attached HW-ULT_dmesg.txt

Test Environment:
````````````````````````````````````
Kernel: tag drm-intel-testing-2015-07-31 (4.2-rc4) from git://anongit.freedesktop.org/drm-intel
Mesa: mesa-10.6.3 from http://cgit.freedesktop.org/mesa/mesa/
Xf86_video_intel: 2.99.917 from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
Libdrm: libdrm-2.4.62 from http://cgit.freedesktop.org/mesa/drm/
Cairo: 1.14.2 from http://cgit.freedesktop.org/cairo
libva: libva-1.6.0 from http://cgit.freedesktop.org/libva/
intel-driver: 1.6.0. from http://cgit.freedesktop.org/vaapi/intel-driver
xorg: 1.17.99 installed with script git_xorg.sh
Xserver: xorg-server-1.17.2 from http://cgit.freedesktop.org/xorg/xserver
Intel-gpu-tools: 1.11 from http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/



Also add the output of the test with debug parameter in order to provide more useful information : 

gfx@gfx-031:~/dev/graphic/intel-gpu-tools/tests$ time ./gem_render_tiled_blits --debug --run-subtest swap-thrash
IGT-Version: 1.11-gb88212c (x86_64) (Linux: 4.2.0-rc4-drm-intel-testing-ww32+ x86_64)
(gem_render_tiled_blits:7656) drmtest-DEBUG: Test requirement passed: fd >= 0
Test assertion failure function igt_get_stop_rings, file igt_gt.c:284:
Failed assertion: fd >= 0
Last errno: 13, Permission denied
Stack trace:
  #0 [__igt_fail_assert+0xf1]
  #1 [igt_get_stop_rings+0x13f]
  #2 [check_stop_rings+0xa]
  #3 [gem_quiescent_gpu+0x28]
  #4 [drm_open_any+0x3b]
  #5 [__real_main202+0x30]
  #6 [_start+0x0]
  #7 [__libc_start_main+0xf5]
  #8 [_start+0x29]
  #9 [<unknown>+0x29]
Test gem_render_tiled_blits failed.
**** DEBUG ****
(gem_render_tiled_blits:7656) drmtest-DEBUG: Test requirement passed: fd >= 0
Test assertion failure function igt_get_stop_rings, file igt_gt.c:284:
Failed assertion: fd >= 0
Last errno: 13, Permission denied
****  END  ****
Subtest swap-thrash: FAIL
Exiting with status code 99

If you need more information feel free to ask for it
Comment 5 Humberto Israel Perez Rodriguez 2015-08-12 01:28:02 UTC
Created attachment 117633 [details]
HW-ULT_dmesg.txt
Comment 6 Humberto Israel Perez Rodriguez 2015-08-12 05:12:37 UTC
Created attachment 117638 [details]
HW-ULT_2_dmesg.txt

Also keeps failing the subtest "gem_render_linear_blits@swap-thrash" with same configuration that above.

Attached HW-ULT_2_dmesg.txt as kernel log
Comment 7 Chris Wilson 2015-08-12 08:14:28 UTC
(In reply to Humberto Israel Perez Rodriguez from comment #4)
> With the latest test environment and HSW-ULT platform this test keeps
> failing. 

Please don't hid a test bug report inside another. That a swap-thrash test is slow is expected, and so there is little impetus to try and improve it (we have to balance the ability to detect an error with the swap path, which may depend upon physical page location and a thousand other factors - i.e. the test has to be a bit of shotgun in order to provide sufficient confidence). However, we do not expect it to ever FAIL.

FAIL != TIMEOUT
Comment 8 Jairo Miramontes 2015-08-14 18:26:02 UTC
Created attachment 117692 [details]
dmesg log

I am getting TIMEOUT as well  on swap-thrash using the following configuration

Kernel drm-intel-testing-2015-07-31 (kernel 4.2-rc4).

BYT-M

Hardware
Platform: Baytrail-M
CPU: Intel(R) Celeron(R) CPU  N2820  @ 2.13GHz

Software
Linux distribution: Ubuntu 14.04.02 LTS 64 bits
BIOS: 1.10
Ksc: 1.0
Kernel: drm-intel-testing-2015-07-31 (kernel 4.2-rc4). git://anongit.freedesktop.org/drm-intel 
Mesa: mesa-10.6.3 from http://cgit.freedesktop.org/mesa/mesa/
Xf86_video_intel: 2.99.917 from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
Libdrm: libdrm-2.4.62 from http://cgit.freedesktop.org/mesa/drm/
Cairo: 1.14.2 from http://cgit.freedesktop.org/cairo
libva: libva-1.6.0 from http://cgit.freedesktop.org/libva/
intel-driver: 1.6.0. from http://cgit.freedesktop.org/vaapi/intel-driver
xorg: 1.17.99 installed with script git_xorg.sh
Xserver: xorg-server-1.17.2 from http://cgit.freedesktop.org/xorg/xserver
Intel-gpu-tools: 1.11 from http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/
Comment 9 Elio 2015-10-01 18:08:05 UTC
The following test cases are showing same behavior:

gem_render_tiled_blits@swap-thrash:

Configuration:

Kernel 4.3.0-rc8-drm-intel-testing-2015-08-28
Mesa: mesa-10.6.7 from http://cgit.freedesktop.org/mesa/mesa/
Xf86_video_intel: 2.99.917 from
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
Libdrm: libdrm-2.4.64 from http://cgit.freedesktop.org/mesa/drm/
Cairo: 1.14.2 from http://cgit.freedesktop.org/cairo
libva: libva-1.6.0 from http://cgit.freedesktop.org/libva/
intel-driver: 1.6.1. from http://cgit.freedesktop.org/vaapi/intel-driver
xorg: 1.17.99 installed with script git_xorg.sh
Xserver: xorg-server-1.17.2 from http://cgit.freedesktop.org/xorg/xserver
Intel-gpu-tools: 1.12 from http://cgit.freedesktop.org/xorg/app/intel-gpu
Comment 10 maria guadalupe 2016-04-01 19:48:32 UTC
This bug was also reproduced on BXT under the following configuration


Hardware configuration
=======================
Platform     BXT - P (APL)
Motherboard model  Apollo Lake
Motherboard type    NOTEBOOK Hand Held
Motherboard manufacturer Intel Corp.
CPU family   Other
CPU information    06/5c
GPU Card     Intel Corporation Device 5a84 (rev 03) (prog-if 00 [VGA controller])
Memory ram   8 GB


Software configuration
=======================
 --> Component : drm 
       url : http://cgit.freedesktop.org/mesa/drm 
       tag : libdrm-2.4.67-11-gea78c17 
       commit : ea78c17 
       author : Emil Velikov <emil.l.velikov@gmail.com> 
       age : 20 hours ago 
 --> Component : mesa 
       url : http://cgit.freedesktop.org/mesa/mesa 
       tag : mesa-11.1.2 
       commit : 7bcd827 
       author : Emil Velikov <emil.velikov@collabora.com> 
       age : 7 weeks ago 
 --> Component : xf86-video-intel 
       url : http://cgit.freedesktop.org/xorg/driver/xf86-video-intel 
       tag : 2.99.917-590-g094924f 
       commit : 094924f 
       author : Chris Wilson <chris@chris-wilson.co.uk> 
       age : 4 days ago 
 --> Component : libva 
       url : http://cgit.freedesktop.org/libva/ 
       tag : libva-1.7.0-1-g2339d10 
       commit : 2339d10 
       author : Xiang Haihao <haihao.xiang@intel.com> 
       age : 13 days ago 
 --> Component : vaapi (intel-driver) 
       url : http://cgit.freedesktop.org/vaapi/intel-driver 
       tag : 1.7.0-5-g759e44d 
       commit : 759e44d 
       author : peng.chen <peng.c.chen@intel.com> 
       age : 13 days ago 
 --> Component : cairo 
       url : http://cgit.freedesktop.org/cairo 
       tag : 1.15.2 
       commit : db8a7f1 
       author : Bryce Harrington <bryce@osg.samsung.com> 
       age : 4 months ago 
 --> Component : xserver 
       url :  http://cgit.freedesktop.org/xorg/xserver 
       tag : xorg-server-1.18.0-254-g44e1c97 
       commit : 44e1c97 
       author : Olivier Fourdan <ofourdan@redhat.com> 
       age : 8 days ago 
 --> Component : intel-gpu-tools 
       url : http://cgit.freedesktop.org/xorg/app/intel-gpu-tools 
       tag : intel-gpu-tools-1.14-129-g41a26b5 
       commit : 41a26b5 
       author : Chris Wilson <chris@chris-wilson.co.uk> 
       age : 26 hours ago  


kernel configuration
=====================
Branch : drm-intel-nightly
commit f5d413cccefa1f93d64c34f357151d42add63a84
Author: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Date:   Thu Mar 24 14:35:16 2016 +0000

    drm-intel-nightly: 2016y-03m-24d-14h-34m-29s UTC integration manifest
Kernel version : 4.5.0
Architecture : source amd64 all
Comment 11 Humberto Israel Perez Rodriguez 2016-05-26 20:36:24 UTC
with piglit this test shows timeout but running by separatly it fail

test : igt@gem_render_tiled_blits@swap-thrash

test output
============================
(gem_render_tiled_blits:1880) drmtest-DEBUG: Test requirement passed: fd >= 0
(gem_render_tiled_blits:1880) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_render_tiled_blits:1880) igt-core-DEBUG: Starting subtest: swap-thrash
(gem_render_tiled_blits:1880) DEBUG: Test requirement passed: swap_mb > 0
(gem_render_tiled_blits:1880) intel-os-DEBUG: Checking 9,594 surfaces of size 1,048,576 bytes (total 10,064,953,344) against RAM + swap
(gem_render_tiled_blits:1880) intel-os-DEBUG: Test requirement passed: __intel_check_memory(count, size, mode, &required, &total)
(gem_render_tiled_blits:1880) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_render_tiled_blits:1880) DEBUG: Test requirement passed: render_copy
(gem_render_tiled_blits:1880) ioctl-wrappers-DEBUG: Test requirement passed: __gem_set_caching(fd, handle, caching) == 0
Using a snoop linear buffer for comparisons
Verifying initialisation...
gem_render_tiled_blits: rendercopy_gen9.c:178: gen6_render_flush: Assertion `ret == 0' failed.
Received signal SIGABRT.


the dmesg output could be not relevant here because are only debug messages
==========================================================================
[  346.884241] gem_render_tiled_blits: executing
[  346.884334] [drm:i915_gem_open]
[  346.884451] [drm:i915_gem_open]
[  346.884520] gem_render_tiled_blits: starting subtest swap-thrash
[  354.923144] [drm:skl_update_scaler_plane] Updating scaler for [PLANE:23] scaler_user index 0.0
[  354.923146] [drm:skl_update_scaler_plane] Updating scaler for [PLANE:29] scaler_user index 1.4
[  354.923146] [drm:skl_update_scaler_plane] Updating scaler for [PLANE:34] scaler_user index 2.8


Gfx stack information
===============================================
 --> Component : drm 
	 tag : libdrm-2.4.68-4-g7aab852 
	 commit : 7aab852 
 --> Component : mesa 
	 tag : mesa-11.1.2 
	 commit : 7bcd827 
 --> Component : cairo 
	 tag : 1.15.2 
	 commit : db8a7f1 
 --> Component : intel-gpu-tools
	 tag : intel-gpu-tools-1.14-346-gcce2ff0
	 commit : cce2ff0


Software information
===============================================
Kernel version                      : 4.6.0-rc7-drm-intel-nightly-ww20-commit-5528ede+
Linux distribution                  : Ubuntu 15.10
Architecture                        : 64-bit
Bios revision                       : 138.22
KSC revision                        : 1.12
DMC revision                        : 1.07
GUC revision                        : 8.7


Hardware information
===============================================
Platform                            : BXT-P
Motherboard model                   : Broxton P
Motherboard type                    : NOTEBOOK Hand Held
Motherboard manufacturer            : Intel Corp.
CPU family                          : B1
CPU information                     : 06/5c
GPU Card                            : Intel Corporation Device 5a84 (rev 0a) (prog-if 00 [VGA controller])


kernel
===============================================
commit 2ec823981d62c56d1511bda42b8295e31ece800f
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sun May 22 18:23:13 2016 +0200

    drm-intel-nightly: 2016y-05m-22d-16h-22m-45s UTC integration manifest
Comment 12 Luis Botello 2016-05-27 22:18:45 UTC
This isuue is also seen on KBL with the following config:

Gfx stack information
===============================================
--> Component : drm 
                 tag : libdrm-2.4.68-4-g7aab852 
                 commit : 7aab852 
 --> Component : mesa 
                 tag : mesa-11.1.2 
                 commit : 7bcd827 
 --> Component : cairo 
                 tag : 1.15.2 
                 commit : db8a7f1 
 --> Component : intel-gpu-tools
                tag : intel-gpu-tools-1.14-346-gcce2ff0
                commit : cce2ff0


Software information
============================

Kernel version                      : 4.6.0-nightly+
Linux distribution                  : Ubuntu 15.10
Architecture                        : 64-bit
Bios revision                       : 28.1
KSC revision                        : 1.15


Hardware information 
=============================

Platform                            : SKL-Y to KBL (RVP3)
Motherboard model                   : Kabylake Client platform
Motherboard manufacturer            : Intel Corporation
CPU information                     : Genuine Intel(R) CPU 0000 @ 0.90GHz
GPU Card                            : Intel Corporation Device 591e (prog-if 00 [VGA controller])


|=== kernel information ===|

commit 2ec823981d62c56d1511bda42b8295e31ece800f
Comment 13 Humberto Israel Perez Rodriguez 2016-06-03 21:20:35 UTC
the issue is present with the following configuration :


Tests cases
===============================================
igt@gem_render_tiled_blits@swap-thrash


Gfx stack information
===============================================
--> Component : drm 
	 tag : libdrm-2.4.68 
	 commit : fc09c5a 
--> Component : cairo 
	 tag : 1.15.2 
	 commit : db8a7f1 
--> Component : intel-gpu-tools 
	 tag : intel-gpu-tools-1.14-348-g303b380 
	 commit : 303b380 
 
Software information
===============================================
Kernel version                      : 4.6.0-drm-intel-nightly-ww23-commit-fb023a2+
Linux distribution                  : Ubuntu 16.04
Architecture                        : 64-bit
Bios revision                       : 138.25
KSC revision                        : 1.12
DMC revision                        : 1.07

Hardware information
===============================================
Platform                            : BXT-P
Motherboard model                   : Broxton P
Motherboard type                    : NOTEBOOK Hand Held
Motherboard manufacturer            : Intel Corp.
CPU family                          : B1
CPU information                     : 06/5c
GPU Card                            : Intel Corporation Device 5a84 (rev 0a) (prog-if 00 [VGA controller])

kernel
===============================================
commit fb023a2062df06c9e097e1f8f2bcf252194b9413
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon May 30 10:46:14 2016 +0200

    drm-intel-nightly: 2016y-05m-30d-08h-45m-53s UTC integration manifest
Comment 14 cprigent 2016-07-06 13:58:59 UTC
Test is Pass on APL. It needs more than 30 minutes.

# ./gem_render_tiled_blits --r swap-thrash
IGT-Version: 1.15-g88c1f7c (x86_64) (Linux: 4.7.0-rc5-nightly+ x86_64)
Using a snoop linear buffer for comparisons
Verifying initialisation...
Cyclic blits, forward...
Cyclic blits, backward...
Random blits...
Subtest swap-thrash: SUCCESS (1937.647s)

Platform: APL system
CPU Name : Intel(R) Genuine Processor @ 1.1 GHz (family: 6, model: 12, stepping: 9) 4 cores
QDF : Q6HE
SoC : B1
CRB : Apollo Lake DDR3L RVP1A FAB2
Reworks : R19, R20

Software 
Bios: 144_B10 APLK_B0_IFWI_X64_R_2016_06_27_0956_SPI_RVP1.bin from \\gar\ec\proj\ba\CCG\APL BIOS\External\BIOS_Release\Daily\v144_10_2016_WW27.1\IFWI\IFWI_RVP1_Release\IFWI
KSC: 1.15
Linux distribution: Ubuntu 16.04 64 bits
Kernel: drm-intel-nightly 4.7.0-rc5 2fe5da8 from http://cgit.freedesktop.org/drm-intel/
               commit 2fe5da8adcbe5a34830b98c63878eea756e977a2
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sat Jul 2 19:32:50 2016 +0100
drm-intel-nightly: 2016y-07m-02d-18h-31m-39s UTC integration manifest
drm: libdrm-2.4.68-11 7996a87 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-11.2.2 3a9f628from git://anongit.freedesktop.org/mesa/mesa
cairo: 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
server: xorg-server-1.18.0-443 3762edd from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel: 2.99.917-674 9154dff from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva: libva-1.7.0-26 c36971c from git://git.freedesktop.org/git/vaapi/libva
vaapi-intel-driver: 1.7.0-53 bcde10d from git://git.freedesktop.org/git/vaapi/intel-driver
GuC 8.7
DMC 1.07 from https://01.org/linuxgraphics/downloads/broxton-dmc-1.07
Intel-Gpu-Tools 1.15-87 376b813 from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git

I removed APL from summary and "i915 platform". Please check on the other platforms.
Comment 15 Elio 2016-11-23 22:23:51 UTC
The problem persist with the following configuration on BYT:

Platform BYT: Acer Aspire XC-603
CPU: Intel(R) Pentium(R) CPU  J2900  @ 2.41GHz (family 6, model 55, stepping 8)
Motherboard: Aspire XC-603
GPU: Intel® HD Graphics - Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

Software
Bios: P11-B2
Linux distribution: Ubuntu 16.04 64 bits

Kernel: 4.9.0-rc4 91e164f branch drm-intel-nightly from http://cgit.freedesktop.org/drm-intel/ 
  commit 91e164fea17d3e5366048b6eae3c6eea4e14e9fe
  Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
  Date:   Mon Nov 14 16:31:06 2016 +0200
  drm-intel-nightly: 2016y-11m-14d-14h-30m-30s UTC integration manifest

libdrm-2.4.71-13 670f1e4 from git://anongit.freedesktop.org/mesa/drm
mesa: mesa-13.0.0 df1b0a5 from git://anongit.freedesktop.org/mesa/mesa
cairo 1.15.2 db8a7f1 from git://anongit.freedesktop.org/cairo
xorg-server-1.18.99.902-2 7513da4 from git://git.freedesktop.org/git/xorg/xserver
xf86-video-intel 2.99.917-731 d1d14f2 from git://git.freedesktop.org/git/xorg/driver/xf86-video-intel
libva-1.7.2-40 3a7547b from git://git.freedesktop.org/git/vaapi/libva 
vaapi-intel-driver: 1.7.2-157 55a538c from git://git.freedesktop.org/git/vaapi/intel-driver
intel-gpu-tools-1.16-132 773ac7c from http://anongit.freedesktop.org/git/xorg/app/intel-gpu-tools.git

External screen: DELL U2312HM (VGA)

Error:
Out of memory: Kill process 4318 (gem_render_line) score 1000 or sacrifice child
[49101.282456] Killed process 4318 (gem_render_line) total-vm:30116kB, anon-rss:2428kB, file-rss:1844kB, shmem-rss:0kB
[49101.283454] oom_reaper: reaped process 4318 (gem_render_line), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB
Comment 16 Jari Tahvanainen 2017-03-27 10:04:54 UTC
Jairo - please retest on KBL with the latest drm-tip (and other platforms). Note comment 14.
Comment 17 Elio 2017-04-05 20:08:32 UTC
The problem is getting back on APL

Output:

subtest swap-thrash
IGT-Version: 1.18-g56741ce (x86_64) (Linux: 4.11.0-rc5-drm-tip-qa-ww14-commit-5bc82ec+ x86_64)
Using a snoop linear buffer for comparisons
Killed


DMesg failure:

[  147.711546] Out of memory: Kill process 1536 (gem_render_tile) score 1000 or sacrifice child
[  147.711565] Killed process 1536 (gem_render_tile) total-vm:78280kB, anon-rss:1004kB, file-rss:3412kB, shmem-rss:0kB
[  147.712272] oom_reaper: reaped process 1536 (gem_render_tile), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB
[  316.382588] mce: [Hardware Error]: Machine check events logged
Comment 18 Humberto Israel Perez Rodriguez 2017-05-30 21:19:12 UTC
with the latest configuration on BDW, the following test was fail

gem_render_tiled_blits@swap-thrash

IGT-Version: 1.18-g00ce341 (x86_64) (Linux: 4.12.0-rc3-drm-tip-ww22-commit-75397b6+ x86_64)
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: is_i915_device(fd) && has_known_intel_chipset(fd)
(gem_render_tiled_blits:1566) ioctl-wrappers-DEBUG: Test requirement passed: err == 0
(gem_render_tiled_blits:1566) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_render_tiled_blits:1566) igt-core-DEBUG: Starting subtest: swap-thrash
(gem_render_tiled_blits:1566) DEBUG: Test requirement passed: swap_mb > 0
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_tiled_blits:1566) intel-os-DEBUG: Checking 15,701 surfaces of size 1,048,576 bytes (total 16,471,732,224) against RAM + swap
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_tiled_blits:1566) intel-os-DEBUG: Test requirement passed: __intel_check_memory(count, size, mode, &required, &total)
(gem_render_tiled_blits:1566) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_render_tiled_blits:1566) DEBUG: Test requirement passed: render_copy
(gem_render_tiled_blits:1566) ioctl-wrappers-DEBUG: Test requirement passed: __gem_set_caching(fd, handle, caching) == 0
Using a snoop linear buffer for comparisons
Verifying initialisation...
(gem_render_tiled_blits:1566) CRITICAL: Test assertion failure function check_bo, file gem_render_tiled_blits.c:85:
(gem_render_tiled_blits:1566) CRITICAL: Failed assertion: ptr[i] == val
(gem_render_tiled_blits:1566) CRITICAL: Expected 0xf4080000, found 0xf4040000 at offset 0x00000000
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [check_bo+0x128]
  #2 [<unknown>+0x128]
Subtest swap-thrash failed.
**** DEBUG ****
(gem_render_tiled_blits:1566) DEBUG: Test requirement passed: swap_mb > 0
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_tiled_blits:1566) intel-os-DEBUG: Checking 15,701 surfaces of size 1,048,576 bytes (total 16,471,732,224) against RAM + swap
(gem_render_tiled_blits:1566) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_tiled_blits:1566) intel-os-DEBUG: Test requirement passed: __intel_check_memory(count, size, mode, &required, &total)
(gem_render_tiled_blits:1566) igt-core-DEBUG: Test requirement passed: !igt_run_in_simulation()
(gem_render_tiled_blits:1566) DEBUG: Test requirement passed: render_copy
(gem_render_tiled_blits:1566) ioctl-wrappers-DEBUG: Test requirement passed: __gem_set_caching(fd, handle, caching) == 0
(gem_render_tiled_blits:1566) INFO: Using a snoop linear buffer for comparisons
(gem_render_tiled_blits:1566) INFO: Verifying initialisation...
(gem_render_tiled_blits:1566) CRITICAL: Test assertion failure function check_bo, file gem_render_tiled_blits.c:85:
(gem_render_tiled_blits:1566) CRITICAL: Failed assertion: ptr[i] == val
(gem_render_tiled_blits:1566) CRITICAL: Expected 0xf4080000, found 0xf4040000 at offset 0x00000000
****  END  ****
Subtest swap-thrash: FAIL (239.255s)
(gem_render_tiled_blits:1566) igt-core-DEBUG: Exiting with status code 99
(gem_render_tiled_blits:1566) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'


Component: drm
    tag: libdrm-2.4.80-18-gce9e3ba
    commit: ce9e3ba6e2cc65e1e9e6e05a5f326c4dd25ab2c4

Component: cairo
    tag: 1.15.4-22-g0fd0fd0
    commit: 0fd0fd0ae9ad8cfb177bb844091de98c0235917e

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.18-211-g00ce341
    commit: 00ce341b95c718611689ded8ccec45086186c5b7

Component: piglit
    tag: piglit-v1
    commit: ebbb9c5dcc6a637884d54e06eb430a8c14993413

	
Kernel version
=========================================
commit 75397b60fe84eb5125a78a5ee304def86b761994
Author:     Chris Wilson <chris@chris-wilson.co.uk>
AuthorDate: Tue May 30 12:56:32 2017 +0100
Commit:     Chris Wilson <chris@chris-wilson.co.uk>
CommitDate: Tue May 30 12:56:32 2017 +0100

    drm-tip: 2017y-05m-30d-11h-55m-42s UTC integration manifest
Comment 19 Armando Antonio 2017-07-05 20:42:03 UTC
The following test fail on IVB with latest configuration


testlist
====================================================
igt@kms_pipe_color@invalid-ctm-matrix-sizes
igt@kms_pipe_color@invalid-lut-sizes



Graphic Stack
====================================================
Component: drm
    tag: libdrm-2.4.81-24-g3095cc8
    commit: 3095cc8eaba1aa87ad38c04ae2b1eabe30f7e16c

Component: cairo
    tag: 1.15.6-2-g57b4050
    commit: 57b40507dda3f58dfc8635548d606b86dc7bcf51

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.19-57-g6fcc8e8
    commit: 6fcc8e8b247661c7950b998e0b95141ffbd6b833

Component: piglit
    tag: piglit-v1
    commit: c8f4fd9eeb298a2ef0855927f22634f794ef3eff


======================================
             Hardware
======================================
platform                   : Ivy Bridge
motherboard model          : Inspiron660
motherboard id             : 0XR1GT
form factor                : Desktop
manufacturer               : DellInc.
cpu family                 : Core i5
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz
gpu card                   : Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.7 GB
max memory ram             : 8 GB
cpu thread                 : 4
cpu core                   : 4
cpu model                  : 58
cpu stepping               : 9
socket                     : Socket BGA1155
signature                  : Type 0, Family 6, Model 58, Stepping 9
hard drive                 : 74GiB (80GB)
current cd clock frequency : 400000 kHz
maximum cd clock frequency : 400000 kHz
displays connected         : VGA-1 HDMI-A-1
Comment 20 Armando Antonio 2017-07-05 21:03:39 UTC
Sorry this is the test list
Tests cases
===============================================
igt@gem_render_tiled_blits@swap-thrash
Comment 21 maria guadalupe 2017-07-12 16:17:24 UTC
issue is still present over BDW with the following configuration 

test
=====================================
igt@gem_render_tiled_blits@swap-thrash

 Software
======================================
kernel version              : 4.12.0-drm-tip-ww28-commit-f1619bb+
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda3)

======================================
        Graphic drivers
======================================
modesetting                 : enabled
modesetting compiled for    : 1.18.4 X.Org Video Driver
xorg-xserver                : 1.18.4
libdrm                      : 2.4.70
libva                       : 1.7.1-2
vaapi (intel-driver)        : 1.7.1
cairo                       : 1.14.6-1build1
intel-gpu-tools             : 1.16-1

======================================
             Hardware
======================================
platform                   : Broadwell
motherboard id             : NUC5i5MYBE
form factor                : Desktop
cpu family                 : Core i5
cpu information            : Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz
gpu card                   : Intel Corporation HD Graphics 5500 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 11.62 GB
max memory ram             : 16 GB
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 111GiB (120GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : DP-1 DP-2

======================================
             kernel parameters
======================================
quiet drm.debug=0x1e resume=/dev/sda3 fastboot
Comment 22 Hector Velazquez 2017-07-26 19:32:41 UTC
The following test FAIL on IVB with this configuration

Tests List:

igt@gem_render_tiled_blits@swap-thrash

====================================================
Test Log
====================================================
No log was generated by the test, the system look freeze and in the machine and ssh connection looks not operative....

====================================================
latest dmesg messages
====================================================

[32m[ 1626.160646] [0m[33mConsole[0m: switching to colour dummy device 80x25
[32m[ 1626.160902] [0m[33m[IGT] gem_render_tiled_blits[0m: executing
[32m[ 1626.181569] [0m[33m[IGT] gem_render_tiled_blits[0m: starting subtest swap-thrash
[32m[ 1626.182881] [0m[33mgem_render_tile (1385)[0m: drop_caches: 4


This is my configuration:

====================================================
Graphic Stack
====================================================
Component: drm
    tag: libdrm-2.4.81-33-g3876bc2
    commit: 3876bc246a07070a6043159cd7623d4def9bbd4c

Component: cairo
    tag: 1.15.6-2-g57b4050
    commit: 57b40507dda3f58dfc8635548d606b86dc7bcf51

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.19-112-g493151b
    commit: 493151b0768aa4ca535cef49cb7efa174a9c3a77

Component: piglit
    tag: piglit-v1
    commit: 973892687cf5c2f8e2dbe1d22998b82736643787

======================================
             Hardware
======================================
motherboard model          : 2349AZ2
motherboard id             : 2349AZ2
form factor                : Notebook
manufacturer               : LENOVO
cpu family                 : Core i5
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
gpu card                   : Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 3.71 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 58
cpu stepping               : 9
socket                     : Socket rPGA988B
signature                  : Type 0, Family 6, Model 58, Stepping 9
hard drive                 : 111GiB (120GB)
current cd clock frequency : 400000 kHz
maximum cd clock frequency : 400000 kHz
displays connected         : LVDS-1 DP-1
Comment 23 Elizabeth 2017-08-23 21:18:16 UTC
On BXT this test are now skipped, is this behavior expected? Thank you.

igt@gem_render_tiled_blits@aperture-shrink, Not run, this test was skip
igt@gem_render_tiled_blits@aperture-thrash, Not run, this test was skip
igt@gem_render_tiled_blits@basic, Not run, this test was skip
igt@gem_render_tiled_blits@swap-thrash, Not run, this test was skip

Gfx stack:
=====================================================
Component: drm
    tag: libdrm-2.4.81-46-g9d133dd
    commit: 9d133dd08720d80dfc8ce098bf0972ebd05c454d

Component: cairo
    tag: 1.15.6-14-gf351595
    commit: f3515954e0bc9c9ca413a84a8dd842145cec83a7

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.19-193-g5a17ee2
    commit: 5a17ee2c8f9013f5db852d27564b837f9f2c5a9f

Component: piglit
    tag: piglit-v1
    commit: 2a7047a32bb3a9a4fad5bea0a8185d63af6bddf3
======================================================
commit ad6ab9f96437f0cb1f4d8a7840fd9eeb894eb12e
Author:     Gustavo Padovan <gustavo.padovan@collabora.com>
AuthorDate: Fri Aug 18 15:26:42 2017 -0300
Commit:     Gustavo Padovan <gustavo.padovan@collabora.com>
CommitDate: Fri Aug 18 15:26:42 2017 -0300

    drm-tip: 2017y-08m-18d-18h-21m-46s UTC integration manifest
Comment 24 Chris Wilson 2017-10-06 20:17:56 UTC
*** Bug 103083 has been marked as a duplicate of this bug. ***
Comment 25 Elizabeth 2017-12-07 18:24:27 UTC
All of our platforms, BDW, BSW, BXT, BYT, CFL, CNL, GLK, HSW, IVB, KBL, SKL, SNB, are either timeout by piglit or hanged with this test.
Comment 26 Elizabeth 2018-02-12 21:24:47 UTC
(02:08 PM) [gfx@gfx-desktop] [tests]$ : time sudo -E ./gem_render_tiled_blits --r swap-thrash
[sudo] password for gfx:
IGT-Version: 1.21-g94bd67c (x86_64) (Linux: 4.15.0-drm-tip-ww6-commit-8970187+ x86_64)
Using a snoop linear buffer for comparisons
Verifying initialisation...
Cyclic blits, forward...
Cyclic blits, backward...
Random blits...
Subtest swap-thrash: SUCCESS (2811.529s)

real    46m54.240s
user    1m8.445s
sys     8m10.822s

*** This bug has been marked as a duplicate of bug 91454 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.