Bug 89639 - dEQP-GLES3: textureOffset() call with isampler3d in vertex shader fails with U offset = 7.
Summary: dEQP-GLES3: textureOffset() call with isampler3d in vertex shader fails with ...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-18 07:24 UTC by Samuel Iglesias Gonsálvez
Modified: 2019-09-25 18:53 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Iglesias Gonsálvez 2015-03-18 07:24:31 UTC
The test checks that isampler3d is accessing properly an integer 3D texture with a given offset using textureOffset() shader function. In this case, the offset vector is (7, 3, -8).

According to the PRM, the valid values are from [-8, 7] because it's in 4-bits two's complement, so 7 is the maximum and -8 the minimum. However, only when the value of '7' is present in the first component (U offset) the bug appears.

If I change that value to any other one inside the valid range, it works fine.

By the way, If I modify textureOffset.usampler3d_vertex test to use the same offset vector (7, 3, -8), it fails. It is not a surprise as it has the same sampler type (sample_l). However, sampler3d test works fine in the same conditions.

-----------

Mesa master: 27bf37ba05b69ebf6f373d1637a26b4839265921
Tested on Haswell.

How to reproduce it:

$ cd modules/gles3/
$ ./deqp-gles3 -n dEQP-GLES3.functional.shaders.texture_functions.textureoffset.isampler3d_vertex
Comment 1 Hai 2019-01-10 08:54:43 UTC
I meet similar issues with AMD vega platform. Not sure if it is the driver bug of test case bug.

Following is the test Environment
Platform: KBL-G
CPU: Intel (R) Core (TM) i7-8809G CPU @3.10GHz
GPU: AMD(Radeon RX Vega M GH Graphics); Intel GPU
Memory: 16G
OS: Ubutu18.04
Kernel: 4.19.0
amd driver version: amdgpu-pro-18.40-697810-ubuntu-18.04.tar.xz(Open Stack) 
VK-GL-CTS commit id:54e546a1a0a6fa412ea4c3e3081bbc9518928a6e
Vulkan: mesa 18.2.2
Comment 2 Denis 2019-01-16 12:02:02 UTC
hi, I also checked this test and it still fails:


[me@me-pc gles3]$ ./deqp-gles3 -n dEQP-GLES3.functional.shaders.texture_functions.textureoffset.isampler3d_vertex
Writing test log into TestResults.qpa
dEQP Core git-12aa347f43c85df3a0daf930739551d3f53d3d48 (0x12aa347f) starting..
  target implementation = 'Default'

Test case 'dEQP-GLES3.functional.shaders.texture_functions.textureoffset.isampler3d_vertex'..
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)
  Not supported: 0/1 (0.0%)
  Warnings:      0/1 (0.0%)

Also I didn't find this test in intel-ci. Mark, could you please clarify this thing? I searched in the mesa_master branch.
Comment 3 Mark Janes 2019-01-16 17:06:50 UTC
This test is not located in the mustpass list:

https://android.googlesource.com/platform/external/deqp/+/master/android/cts/master/gles3-master.txt

Usually, this indicates that there is something wrong with the test.  

i965 CI excludes tests that are not in mustpass, because they are not part of our conformance requirements.

I wouldn't recommend spending developer time investigating a buggy deqp test, unless you have reason to believe it should work.
Comment 4 Denis 2019-01-17 08:44:31 UTC
got you. Thanks a lot for clarification!
Comment 5 GitLab Migration User 2019-09-25 18:53:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1479.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.