Bug 89745 - SEGFAULT in Firefox when layers.acceleration.force enabled
Summary: SEGFAULT in Firefox when layers.acceleration.force enabled
Status: RESOLVED DUPLICATE of bug 81680
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-24 10:19 UTC by Kami
Modified: 2015-03-25 10:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kami 2015-03-24 10:19:50 UTC
When I enable layers.acceleration.force enabled on a laptop that utilize Radeon HD 6470M (HP Probook 6560b) the Firefox becomes crashy.

Firefox crash stats:

https://crash-stats.mozilla.com/report/index/9f758b7f-a9b9-45db-907a-432de2150320
https://crash-stats.mozilla.com/report/index/f55b9a9c-cd3c-48c8-802a-da5822150321
https://crash-stats.mozilla.com/report/index/443715bc-90a6-4f9e-9cdc-ce36a2150321

More details about the system:

lspci
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

lshv -C video
  *-display               
       description: VGA compatible controller
       product: Seymour [Radeon HD 6400M/7400M Series]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:46 memory:c0000000-cfffffff memory:d4300000-d431ffff ioport:4000(size=256) memory:d4340000-d435ffff

xserver-xorg-video-radeon                   1:7.3.0-1ubuntu3.1
libdrm-radeon1:amd64                        2.4.56-1~ubuntu2

Linux Godzilla 3.16.0-31-generic #43~14.04.1-Ubuntu SMP Tue Mar 10 20:13:38 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Related Firefox Bugzilla entry:
https://bugzilla.mozilla.org/show_bug.cgi?id=1144529

If you need more information, do not hesitate to ask.
Comment 1 Michel Dänzer 2015-03-25 04:03:53 UTC
We need symbols for the r600_dri.so entries in the crash dumps, see bug 81680.
Comment 2 Kami 2015-03-25 09:54:07 UTC
locate r600_dri.so
/usr/lib/i386-linux-gnu/dri/r600_dri.so
/usr/lib/x86_64-linux-gnu/dri/r600_dri.so

Installed:
sudo apt-get install libgl1-mesa-dri-dbg

addr2line 0x168a2f -e /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
/build/buildd/mesa-10.1.3/build/dri/src/mesa/../../../../src/gallium/auxiliary/util/u_inlines.h:151

addr2line 0x168a34 -e /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
/build/buildd/mesa-10.1.3/build/dri/src/mesa/../../../../src/gallium/auxiliary/util/u_inlines.h:151
Comment 3 Michel Dänzer 2015-03-25 10:05:00 UTC
Looks like the same bug, which has been fixed upstream.

*** This bug has been marked as a duplicate of bug 81680 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.