Bug 89754 - vertexAttrib fails WebGL Conformance test with mesa drivers
Summary: vertexAttrib fails WebGL Conformance test with mesa drivers
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-25 03:57 UTC by Luke
Modified: 2015-03-27 02:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-03-25 03:57:13 UTC
Steps to reproduce:
1. Using an Mesa driver (nouveau or radeon) visit 
https://www.khronos.org/registry/webgl/conformance-suites/1.0.2/conformance/attribs/gl-vertex-attrib-render.html
2. Using a proprietary driver visit
https://www.khronos.org/registry/webgl/conformance-suites/1.0.2/conformance/attribs/gl-vertex-attrib-render.html

Expected results:
Both sets of drivers pass

Actual results:
With both Firefox and Chrome, only the proprietary drivers pass.
Comment 1 Tapani Pälli 2015-03-25 05:21:31 UTC
test passes on i965 driver
Comment 2 Ilia Mirkin 2015-03-26 17:19:10 UTC
I sent a piglit test which should make this easier to debug:

http://patchwork.freedesktop.org/patch/45692/

I believe the problem is that gallium never notices the updated vertex size. I haven't debugged it in detail though. As with the WebGL test, this passes on i965 (HSW), and fails with llvmpipe and softpipe (with DRAW_USE_LLVM=false for good measure).
Comment 3 Ilia Mirkin 2015-03-27 02:39:17 UTC
Fix pushed in 9d1b5febb6. Thanks for reporting!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.