Bug 89848 - i915: framebuffer corruption when switching tty or quitting x-server with kernel >=4.0
Summary: i915: framebuffer corruption when switching tty or quitting x-server with ker...
Status: CLOSED DUPLICATE of bug 85583
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-31 17:36 UTC by Dominic Lindsay
Modified: 2016-10-10 11:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output after framebuffer corruption occurs. (210.66 KB, text/plain)
2015-04-01 12:11 UTC, Dominic Lindsay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Lindsay 2015-03-31 17:36:44 UTC
Using any of the 4.0 kernels I get framebuffer corruption when switching tty or quitting X.
my dmesg output gives:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Some people running 3.19 are getting corruption when running multiple displays, with 'pipe B FIFO underrun'.
Comment 1 Jesse Barnes 2015-03-31 18:13:57 UTC
What does the corruption look like?  Can you attach a picture?  Also, I assume you didn't get this corruption on the last kernel, would it be possible to bisect to the failing commit?
Comment 2 Chris Wilson 2015-03-31 20:07:29 UTC
Please attach your dmesg so we know what hardware you have? Preferably with drm.debug=0x6 set on the kernel command line.
Comment 3 Dominic Lindsay 2015-04-01 12:11:59 UTC
Created attachment 114808 [details]
dmesg output after framebuffer corruption occurs.
Comment 4 Dominic Lindsay 2015-04-01 12:12:37 UTC
The corruption makes the writing 'spin' across the screen, from left to right. 
Sometimes I dont seem to be able to switch tty.

Its hard to get a pic since I cant screen cap. 

If you guys dont mind a phone picture I can upload that. I have attacked a .txt with my dmesg output plus the kernel params set.

I cant do a bisect today, as I would have to learn to do it, I simply don't have time to do it today.

When speaking to some people in IRC they say they get some corruption on their second display on kernel 3.19.
Comment 5 Chris Wilson 2015-04-01 12:15:36 UTC

*** This bug has been marked as a duplicate of bug 85583 ***
Comment 6 Jari Tahvanainen 2016-10-10 11:39:14 UTC
Closing as duplicate of closed+fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.