Bug 89871 - nouveau diver in kernel 3.5.7 - 4.0.0-rc6 on PPC broken
Summary: nouveau diver in kernel 3.5.7 - 4.0.0-rc6 on PPC broken
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: XOrg git
Hardware: PowerPC Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-02 08:51 UTC by Dan Smolik
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output 3.19.3 (51.36 KB, text/plain)
2015-04-02 08:51 UTC, Dan Smolik
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Smolik 2015-04-02 08:51:12 UTC
Created attachment 114825 [details]
dmesg output 3.19.3

I have PowerMac G5 machine with dual PPC. On Debian wheezy Xserver works.
I upgrade to jessie with kernel 3.16 and Xserver stop working. I tested these kernels:

vmlinux-3.4.106
vmlinux-3.5.7
vmlinux-3.7.9
vmlinux-3.8.13
vmlinux-3.14.37
vmlinux-3.17.8
vmlinux-3.18.10
vmlinux-3.19.3
vmlinux-4.0.0-rc6

It looks like that between 3.5.7 and 3.8.13 something change and DRM part of nouveau diver and driver stop working:
I tested above kernels and problem is the same this dmesg output is from 
3.19.3
[drm] Initialized drm 1.1.0 20060810
[   10.548060] checking generic (98020000 10e000) vs hw (98000000 8000000)
[   10.548066] fb: switching to nouveaufb from OFfb NVDA,Displ
[   10.555299] Console: switching to colour dummy device 80x25
[   10.557295] nouveau  [  DEVICE][0000:0a:00.0] BOOT0  : 0x043200a4
[   10.557310] nouveau  [  DEVICE][0000:0a:00.0] Chipset: NV43 (NV43)
[   10.557316] nouveau  [  DEVICE][0000:0a:00.0] Family : NV40
[   10.557567] nouveau ![   VBIOS][0000:0a:00.0] unable to locate usable image
[   10.557575] nouveau E[  DEVICE][0000:0a:00.0] failed to create 0x10000001, -22
[   10.557584] nouveau E[     DRM] failed to create 0x00000080, -22
[   10.558138] nouveau: probe of 0000:0a:00.0 failed with error -22

With older kernel < 3.7.9 nouveau kernel part works but newer Xorg from jessie doesn't detect videocard.
Comment 1 Martin Peres 2019-10-14 13:20:14 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.