Bug 89893 - Windows slow/stall/freeze when minimizing/restoring/etc in Unity 7
Summary: Windows slow/stall/freeze when minimizing/restoring/etc in Unity 7
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-03 16:05 UTC by d3vid
Modified: 2015-10-22 07:03 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Recent xorg log file (22.20 KB, text/plain)
2015-05-13 14:09 UTC, d3vid
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description d3vid 2015-04-03 16:05:11 UTC
Steps to reproduce:

 * Launch Unity desktop session
 * Minimize current window or alt-tab between windows
 * Reveal launcher to click on application
 * Click `Super` to bring up Dash
 * Hold `Super` to bring up Keyboard Shortcuts

What should happen:

Action completes smoothly and quickly.

What happens instead:

 * Action may be slow / animation jerky.
 * Action may stall (animation frozen on given frame, e.g. window partially minimized) - initiating another action cancels first action and second action may succeed (most often calling Guake with F12 seems to solve the issue)
 * Action may freeze - cursor no longer moves - a soft reboot (Alt+PrtScr+REISUB) usually works, otherwise a hard reboot

Notes:

This occurs on Ubuntu 14.04 and 14.10. See https://bugs.launchpad.net/bugs/1314587 for a downstream bug report. It was suggested there that an upstream report would be helpful.

I'm not sure which X.org component this applies to, if there is any additional info I can provide please let me know (also see downstream bug, linked above).
Comment 1 Michel Dänzer 2015-04-14 07:24:02 UTC
Please attach the Xorg log file.
Comment 2 d3vid 2015-05-13 14:09:52 UTC
Created attachment 115741 [details]
Recent xorg log file
Comment 3 Ilia Mirkin 2015-10-22 07:03:09 UTC
There is no mention of nouveau anywhere in here, indications of the other bug are that nouveau vs nvidia doesn't matter, and I see no indication of DRI_PRIME ever getting set. I believe this is miscategorized, it's unclear to me why this is in the fd.o bugtracker at all, sounds like some ubuntu thing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.