Bug 90006 - [BSW] Sometime a specific monitor is black after system boots, even from BIOS.
Summary: [BSW] Sometime a specific monitor is black after system boots, even from BIOS.
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2015-04-13 07:16 UTC by Jeff Zheng
Modified: 2015-05-15 04:34 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

dmesg log (209.25 KB, text/plain)
2015-04-13 07:16 UTC, Jeff Zheng
no flags Details

Description Jeff Zheng 2015-04-13 07:16:34 UTC
Created attachment 115045 [details]
dmesg log

==System Environment==
DP monitor: ASUS PA238Q
BIOS: V59 
Regression: No. Tried on drm-intel-testing-2015_01_30 and still saw this issue. This is weird since I saw PA238Q DP screen worked before. This machine was reworked and the DP screen is black too when I tried to enter into BIOS setting. 

Non-working platforms: BSW

-testing: drm-intel-testing-2015-03-27 (fails)

==Bug detailed description==
When connected to ASUS PA238Q with DP cable and booted system, DP screen is black.

If I connected to Dell U2311Hb, DP screen works.

==Reproduce steps==
1. Disconnect eDP, Connect ASUS PA238Q with DP cable and boot
Comment 1 David Weinehall 2015-04-14 13:02:18 UTC
Am I understanding you correctly that the display doesn't work from BIOS either?

If that's the case then this is (most likely) NOT a DRI/DRM related bug, since the BIOS doesn't use the DRI/DRM drivers.

If something worked before the machine rework, but doesn't work now, it's almost certain that the rework caused this issue...
Comment 2 Jeff Zheng 2015-04-29 05:41:08 UTC
This issue disappears with drm-intel-testing-2015-04-23, it looks to be wrong state of monitor. Close it.
Comment 3 Jeff Zheng 2015-05-15 03:05:21 UTC
This time when I connect SkyWorth (TV) 50E780U with HDMI and the screen is blank. BDW/SKL are fine.

I tested on drm-intel-testing-2015-05-08 with V69 BIOS
Comment 4 Jeff Zheng 2015-05-15 04:34:24 UTC
Close it since it's not driver bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.