Bug 90062 - Video sync problems after quitting X on Broadwell
Summary: Video sync problems after quitting X on Broadwell
Status: RESOLVED DUPLICATE of bug 85583
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-17 03:48 UTC by Nick Bowler
Modified: 2015-04-17 08:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (19.62 KB, text/plain)
2015-04-17 03:48 UTC, Nick Bowler
no flags Details
kernel log (48.84 KB, text/plain)
2015-04-17 03:49 UTC, Nick Bowler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Bowler 2015-04-17 03:48:35 UTC
Created attachment 115142 [details]
Xorg log

On my shiny new Thinkpad X250, when the X server is terminated on the intel
driver, the display becomes completely unstable (video just all messed up,
looks like complete loss of both horizontal and vertical sync).  Starting the
X server again does not correct the issue; the display remains messed up until
reboot.  The final line in the kernel log seems relevant:

[   90.454275] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

To reproduce, I just do startx, then press ctrl+alt+bksp.  Happens every time.

The modesetting driver does not have this problem.

Linux 4.0
X server 1.17.1
xf86-video-intel git
libdrm 2.4.60
Comment 1 Nick Bowler 2015-04-17 03:49:28 UTC
Created attachment 115143 [details]
kernel log
Comment 2 Nick Bowler 2015-04-17 03:53:36 UTC
Forgot to mention... the issue also occurs with the last release of xf86-video-intel 2.99.917
Comment 3 Chris Wilson 2015-04-17 08:06:49 UTC

*** This bug has been marked as a duplicate of bug 85583 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.