Bug 90346 - DispatchSanity_test.GLES2 regression
Summary: DispatchSanity_test.GLES2 regression
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 10.6
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-05-06 18:05 UTC by Vinson Lee
Modified: 2018-12-04 11:54 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2015-05-06 18:05:14 UTC
mesa: 5b2d3480f57168d50ad24cf0b8c9244414bd3701 (master 10.6.0-devel)

make check regression on CentOS 6

$ make check
[...]
[ RUN      ] DispatchSanity_test.GLES2
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x453460
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 460 (BeginQuery)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x453470
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 465 (DeleteQueries)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x452cf0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 466 (EndQuery)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x453770
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 468 (GenQueries)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4527a0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 473 (GetQueryObjectuiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x453060
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 474 (GetQueryiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x452b00
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 476 (IsQuery)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483280
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 564 (UniformMatrix2x3fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483180
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 565 (UniformMatrix2x4fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483200
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 566 (UniformMatrix3x2fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483080
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 567 (UniformMatrix3x4fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483100
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 568 (UniformMatrix4x2fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483000
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 569 (UniformMatrix4x3fv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47f1f0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 571 (BeginTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x53ca60
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 572 (BindBufferBase)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x53c070
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 573 (BindBufferRange)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x540ce0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 576 (ClearBufferfi)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x540ee0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 577 (ClearBufferfv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x541340
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 578 (ClearBufferiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x541150
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 579 (ClearBufferuiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47f130
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 584 (EndTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x45f0d0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 586 (GetFragDataLocation)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x43c6e0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 587 (GetIntegerIndexedvEXT)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x43f4d0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 588 (GetStringi)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47fc70
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 591 (GetTransformFeedbackVarying)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4861e0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 592 (GetUniformuiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4877b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 593 (GetVertexAttribIiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x487720
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 594 (GetVertexAttribIuiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47fe00
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 598 (TransformFeedbackVaryings)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484630
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 599 (Uniform1ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484450
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 600 (Uniform1uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4845c0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 601 (Uniform2ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4843f0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 602 (Uniform2uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484540
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 603 (Uniform3ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484390
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 604 (Uniform3uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4844b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 605 (Uniform4ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484330
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 606 (Uniform4uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x488800
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 613 (VertexAttribIPointer)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x53ebc0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 617 (GetBufferParameteri64v)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x43c650
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 618 (GetInteger64i_v)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x486f80
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 619 (VertexAttribDivisor)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x537b40
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 662 (BlitFramebuffer)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4345b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 670 (FramebufferTextureLayer)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x435150
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 679 (RenderbufferStorageMultisample)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x485e10
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 687 (GetActiveUniformBlockName)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x485c10
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 688 (GetActiveUniformBlockiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x481d60
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 690 (GetActiveUniformsiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x486020
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 691 (GetUniformBlockIndex)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x485f30
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 692 (GetUniformIndices)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x485670
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 693 (UniformBlockBinding)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x53f120
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 694 (CopyBufferSubData)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x461ef0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 695 (ClientWaitSync)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x462050
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 696 (DeleteSync)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x461950
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 697 (FenceSync)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x43e4d0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 698 (GetInteger64v)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x461b40
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 699 (GetSynciv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x461df0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 700 (IsSync)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x461cc0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 701 (WaitSync)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4579b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 717 (BindSampler)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x457b50
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 718 (DeleteSamplers)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x456a70
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 719 (GenSamplers)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x457380
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 722 (GetSamplerParameterfv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x457670
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 723 (GetSamplerParameteriv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x457ad0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 724 (IsSampler)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x459200
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 727 (SamplerParameterf)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x458930
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 728 (SamplerParameterfv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4595e0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 729 (SamplerParameteri)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x458d70
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 730 (SamplerParameteriv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47fb10
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 792 (BindTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47fa00
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 793 (DeleteTransformFeedbacks)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47f690
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 795 (GenTransformFeedbacks)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47fbf0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 796 (IsTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47f070
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 797 (PauseTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47ef90
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 798 (ResumeTransformFeedback)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x5631b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 846 (GetInternalformativ)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47ba60
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 851 (TexStorage2D)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x47ba30
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 852 (TexStorage3D)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x432f50
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 956 (InvalidateFramebuffer)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x432f80
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 957 (InvalidateSubFramebuffer)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4842c0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 995 (ProgramUniform1ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484080
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 996 (ProgramUniform1uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484240
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1003 (ProgramUniform2ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483ff0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1004 (ProgramUniform2uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x4841b0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1011 (ProgramUniform3ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483f60
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1012 (ProgramUniform3uiv)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x484110
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1019 (ProgramUniform4ui)
dispatch_sanity.cpp:170: Failure
Value of: table[i]
  Actual: 0x483ed0
Expected: nop_table[i]
Which is: 0x7fed1ffc1dc0
i = 1020 (ProgramUniform4uiv)
[  FAILED  ] DispatchSanity_test.GLES2 (2 ms)


1c5a57aee109ef513df0d281aadc69db293cc3d8 is the first bad commit
commit 1c5a57aee109ef513df0d281aadc69db293cc3d8
Author: Ian Romanick <ian.d.romanick@intel.com>
Date:   Wed Apr 29 13:15:06 2015 -0700

    glapi/es3.1: Add support for GLES versions > 3.0
    
    Make the checks in the Python script and the generated code more generic
    to support arbitrary GLES versions >= 2.0.
    
    The updated dispatch_sanity.cpp test discovered this problem.  Without
    this, the next patch would erroneously enable GLES 3.1 functions in GLES
    2.0 and GLES 3.0.
    
    Signed-off-by: Ian Romanick <ian.d.romanick@intel.com>
    Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>

:040000 040000 90d039873eaf0f1cb8ae06f54df01a32477e6dce 318f50881aa28314eda3811a946e9dd20bd61b19 M	src
bisect run success
Comment 1 Ian Romanick 2015-05-06 20:10:36 UTC
How are you building?  I don't observe that error here.
Comment 2 Vinson Lee 2015-05-06 20:48:22 UTC
$ ./autogen.sh --disable-dri3 --enable-sysfs --with-dri-drivers=swrast --with-gallium-drivers=swrast
$ make
$ make check
Comment 3 Tapani Pälli 2015-08-17 10:27:36 UTC
Seems like this is fixed now? I could not reproduce using current Mesa (1af0641) and configuring like done in comment #2.
Comment 4 Vinson Lee 2015-08-17 19:15:38 UTC
(In reply to Tapani Pälli from comment #3)
> Seems like this is fixed now? I could not reproduce using current Mesa
> (1af0641) and configuring like done in comment #2.

mesa: 5af71fb5ac4dafed3ecc4b849922208cab76070f (master 11.0.0-devel)

I can still reproduced the DispatchSanity_test.GLES2 regression.
Comment 5 Tapani Pälli 2018-11-15 06:30:41 UTC
I could not reproduce this on 19.0.0-devel, resolving as fixed.
Comment 6 Erik Faye-Lund 2018-12-04 11:54:11 UTC
I believe this one was my bad, when enabling NV_conditional_render in 5213be9fab72548c799b30e320dd1b257534f096.

I reverted it in b55af392d9e81e6c1e06536c22d434f275c429f4. Emil is currently looking into reworking the dispatch generation code to avoid problems like this in the future.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.