Bug 90441 - [bdw] X frontbuffer misaligned
Summary: [bdw] X frontbuffer misaligned
Status: CLOSED DUPLICATE of bug 85583
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-13 22:46 UTC by graeber.manuel
Modified: 2017-07-24 22:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
tty1 (720.75 KB, image/jpeg)
2015-05-13 22:46 UTC, graeber.manuel
no flags Details
X flickers (440.54 KB, image/jpeg)
2015-05-13 22:47 UTC, graeber.manuel
no flags Details
X fails to fit (445.54 KB, image/jpeg)
2015-05-13 22:48 UTC, graeber.manuel
no flags Details
xorg.0.log (22.56 KB, text/plain)
2015-05-13 22:48 UTC, graeber.manuel
no flags Details
xrandr --verbose (6.22 KB, text/plain)
2015-05-13 22:51 UTC, graeber.manuel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description graeber.manuel 2015-05-13 22:46:25 UTC
Created attachment 115752 [details]
tty1

When X is running and I switch to tty1, the screen output constantly flickers around the screen. Switching back to X sometimes stops it, sometimes it just continues or it stops in a position, where the upper left corner is somewhere else. Left to it is the upper right and on top of it the lower left part of the screen.

4.0.3-towo.1-siduction-amd64
x86_64
Lenovo Thinkpad L450
Intel i5-5200U
Comment 1 graeber.manuel 2015-05-13 22:47:37 UTC
Created attachment 115753 [details]
X flickers
Comment 2 graeber.manuel 2015-05-13 22:48:06 UTC
Created attachment 115754 [details]
X fails to fit
Comment 3 graeber.manuel 2015-05-13 22:48:38 UTC
Created attachment 115755 [details]
xorg.0.log
Comment 4 graeber.manuel 2015-05-13 22:51:01 UTC
Created attachment 115756 [details]
xrandr --verbose
Comment 5 Chris Wilson 2015-05-15 09:25:01 UTC
The flicker is an ips bug, the misalignment novel.
Comment 6 Ander Conselvan de Oliveira 2015-06-18 11:01:07 UTC
Is this the same as bug 85583? Anyway, probably worth trying the following patch:

http://patchwork.freedesktop.org/patch/50675/
Comment 7 graeber.manuel 2015-06-19 11:02:32 UTC
That patch fixed it

*** This bug has been marked as a duplicate of bug 85583 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.