Bug 90750 - [BDW Bisected]dEQP-GLES3.functional.pbo.renderbuffer.rgb10_a2_triangles fails
Summary: [BDW Bisected]dEQP-GLES3.functional.pbo.renderbuffer.rgb10_a2_triangles fails
Status: CLOSED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All Linux (All)
: high normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-29 07:44 UTC by lu hua
Modified: 2015-06-15 03:18 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2015-05-29 07:44:14 UTC
System Environment:
--------------------------
Platform: BDW
Libdrm:		(master)libdrm-2.4.61-4-gfde4969176822fe54197b6baa78f8b0ef900baba
Mesa:		(master)10aacf5ae8f3e90e2f0967fbdcf96df93e346e20
Xserver:	(master)xorg-server-1.17.0-157-gcbb7eb73b5399e31a7afb800363504d539df0ecf
Xf86_video_intel:(master)2.99.917-313-gfb1643f0f904eb258da71cd0b8deb8d3ec6dafed
Libva:		(master)4763db1c2133d4e6b92355938ecb6f23a7767b6b
Libva_intel_driver:(master)4a1c4d21f3428b08ef765d7f7de75b97006514ac
Kernel:   (drm-intel-nightly)f9d865e87168eaba908020942f458c40facd6060

Bug detailed description:
-----------------------------
It fails on BDW with Mesa master branch.

Bisect shows: ef0499af255ecd3a9abbd350ace5e00a744adc00 is the first bad comit.
commit ef0499af255ecd3a9abbd350ace5e00a744adc00
Author:     Jason Ekstrand <jason.ekstrand@intel.com>
AuthorDate: Mon Jan 12 16:20:27 2015 -0800
Commit:     Jason Ekstrand <jason.ekstrand@intel.com>
CommitDate: Thu Jan 22 10:36:25 2015 -0800

    i965/pixel_read: Use meta_pbo_GetTexSubImage for PBO ReadPixels

    Since the meta path can do strictly more than the blitter path, we just
    remove the blitter path entirely.

    Reviewed-by: Neil Roberts <neil@linux.intel.com>


output:
dEQP Core 2014.x (0xcafebabe) starting..
  target implementation = 'X11 EGL/GLX'

Test case 'dEQP-GLES3.functional.pbo.renderbuffer.rgb10_a2_triangles'..
  Fail (Fail)
Test case duration in microseconds = 239211 us

DONE!

Test run totals:
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)
  Not supported: 0/1 (0.0%)
  Warnings:      0/1 (0.0%)

Reproduce steps:
---------------------------- 
1. xinit
2. ./deqp-gles3 --deqp-gl-context-type=egl --deqp-case="dEQP-GLES3.functional.pbo.renderbuffer.rgb10_a2_triangles"
Comment 1 Neil Roberts 2015-05-29 11:21:14 UTC

*** This bug has been marked as a duplicate of bug 89314 ***
Comment 2 shuo.wang 2015-06-15 03:18:29 UTC
dEQP issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.