Bug 90823 - [drm] stuck on render ring
Summary: [drm] stuck on render ring
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-02 16:41 UTC by Doa379
Modified: 2017-07-24 22:46 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
syslog (7.90 KB, text/plain)
2015-06-02 16:41 UTC, Doa379
no flags Details
crashdump (2.81 MB, text/plain)
2015-06-02 16:47 UTC, Doa379
no flags Details
/sys/class/drm/card0/error (292.49 KB, application/octet-stream)
2015-06-09 20:28 UTC, Kenny MacDermid
no flags Details
dmesg (7.97 KB, text/plain)
2015-06-09 20:30 UTC, Kenny MacDermid
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doa379 2015-06-02 16:41:51 UTC
Created attachment 116249 [details]
syslog

HD5500 Broadwell GPU hangs when loaded with graphically intensive in applications such as Kodi or Chromium playing multiple HD videos.

syslog and crash dump attached.
Comment 1 Doa379 2015-06-02 16:47:38 UTC
Created attachment 116251 [details]
crashdump
Comment 2 Doa379 2015-06-02 17:38:38 UTC
These are the versions of the components used in the gfx stack.

Debian Stable Jessie 8.

-- Linux image(s): linux-image-3.16.0-4-amd64, linux-image-4.0-4.dmz.1-liquorix-amd64
-- xf86-video-intel (2.99.917)
-- mesa (10.3.2-1) 
-- libdrm (2.4.58-2)
-- libva (1.4.1-1)
-- intel-vaapi-driver (1.4.1-2) 
-- cairo (1.14.0-2.1) 
-- xserver-xorg (1:7.7+7) 


I have also tried using all of the components from Debian Sid/Experimental by building them to the following versions but the same issue remains. Any graphically intensive applications such as showing multiple HD videos gives rise to this error. The issue appears to be random and I don't a specific prescription to recreate it on purpose.

-- Linux image(s): linux-image-3.16.0-4-amd64, linux-image-4.0-4.dmz.1-liquorix-amd64
-- mesa (10.5.5-1)
-- xf86-video-intel (2.99.917)
-- libdrm (2.4.60-3)
-- libva (1.5.1-2) 
-- intel-vaapi-driver (1.5.1-2) 
-- cairo (1.14.2-2) 
-- xserver-xorg (1:7.7+9)
Comment 3 Chris Wilson 2015-06-03 09:55:55 UTC
Do the errors go away with intel_iommu=igfx_off (applied on the kernel commandline in grub)?
Comment 4 Doa379 2015-06-04 17:09:53 UTC
(In reply to Chris Wilson from comment #3)
> Do the errors go away with intel_iommu=igfx_off (applied on the kernel
> commandline in grub)?

Thanks for the feedback. Still testing.
Comment 5 Kenny MacDermid 2015-06-09 20:28:00 UTC
Created attachment 116403 [details]
/sys/class/drm/card0/error

I'm seeing the same issue. This is the error info.
Comment 6 Kenny MacDermid 2015-06-09 20:30:31 UTC
Created attachment 116404 [details]
dmesg

Relevant dmesg output.
Comment 7 Doa379 2015-06-11 09:48:09 UTC
Update.

I haven't had a GPU crash so far, since adding the kernel commandline option intel_iommu=igfx_off as Chris suggested.

I will keep this ticket open for the timebeing and continue monitoring the issue.
Comment 8 Chris Wilson 2015-06-11 09:51:02 UTC
Might as well coalesce the reports - we can split again if we find a fix for one and not others.

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.