Bug 90896 - [BDW] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Summary: [BDW] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIF...
Status: CLOSED DUPLICATE of bug 85583
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-08 11:14 UTC by Francesco Frassinelli
Modified: 2017-07-24 22:46 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
journalctl -k -t kernel > intel_cpu_fifo_underrun_irq_handler-kernel.txt (426.76 KB, text/plain)
2015-06-08 11:14 UTC, Francesco Frassinelli
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Frassinelli 2015-06-08 11:14:00 UTC
Created attachment 116363 [details]
journalctl -k -t kernel > intel_cpu_fifo_underrun_irq_handler-kernel.txt

It happens when switching back from VT to X after a couple of seconds of flickering.

It was found while investigating on: https://bugs.freedesktop.org/show_bug.cgi?id=88944

$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.0.4-303.fc22.x86_64 root=UUID=6d95a3dd-0830-4bf9-94c1-a37232327df9 ro rootflags=subvol=root rd.luks.uuid=luks-81064417-7468-43b9-8e39-2e5e9e332d40 rd.luks.uuid=luks-87e2654d-afaa-402c-a4a7-1d6aa1e2403b rhgb quiet systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M drm.debug=0xe

$ uname -a
Linux winston 4.0.4-303.fc22.x86_64 #1 SMP Thu May 28 12:37:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/system-release
Fedora release 22 (Twenty Two)
Comment 1 Ander Conselvan de Oliveira 2015-06-09 10:46:12 UTC
This might be a duplicate of bug 85583. Could you boot with i915.enable_ips=0 in your kernel command line and report back?
Comment 2 Francesco Frassinelli 2015-06-09 12:34:07 UTC
i915.enable_ips=0 fixes this problem for me. No flickering, no FIFO underrun.
Comment 3 Ander Conselvan de Oliveira 2015-06-09 13:11:32 UTC

*** This bug has been marked as a duplicate of bug 85583 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.