Bug 91050 - [SKL-MBL][Linux]: eDP with 3840x2160 resolution is not lighting up
Summary: [SKL-MBL][Linux]: eDP with 3840x2160 resolution is not lighting up
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Vijayakannan Ayyathurai
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-22 06:53 UTC by Vijayakannan Ayyathurai
Modified: 2016-09-07 11:29 UTC (History)
8 users (show)

See Also:
i915 platform: SKL
i915 features: display/eDP


Attachments
xrandr.log (1.42 KB, text/plain)
2015-06-22 06:53 UTC, Vijayakannan Ayyathurai
no flags Details
dmesg_4840x2160.log (153.24 KB, text/plain)
2015-06-22 06:55 UTC, Vijayakannan Ayyathurai
no flags Details
dmesg_dmc_loaded.log (63.86 KB, text/plain)
2015-06-30 13:23 UTC, Vijayakannan Ayyathurai
no flags Details
eDP_Resolution_3840x2160_xorg (20.74 KB, text/plain)
2015-08-05 09:36 UTC, Vijayakannan Ayyathurai
no flags Details
ddi translation (7.20 KB, patch)
2015-08-20 19:53 UTC, Rodrigo Vivi
no flags Details | Splinter Review
xrandr.log (1.46 KB, text/plain)
2016-06-02 20:18 UTC, maria guadalupe
no flags Details
dmesg.log (60.60 KB, text/plain)
2016-06-02 20:19 UTC, maria guadalupe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vijayakannan Ayyathurai 2015-06-22 06:53:43 UTC
Created attachment 116642 [details]
xrandr.log

System Environment:
--------------------------
Platform: SKL Linux
Kernel - (4.1-rc8) 644bfe268feb04544d89b52edba6bef6a2661ddc
drm kernel merge : 2015y-06m-15d-16h-39m-55s
Libdrm - (2.4.61) a1acffd4e0968ffa65b673163574188a00c9ab7e
Mesa - (10.7.0-devel) 7518fc3c66e9b5703b987bccca7970a344deadfa
vaapi - (0.38.0) 4763db1c2133d4e6b92355938ecb6f23a7767b6b
libva - (1.6.0.pre1) 4763db1c2133d4e6b92355938ecb6f23a7767b6b
intel-driver (1.6.0.pre1) 4a1c4d21f3428b08ef765d7f7de75b97006514ac

eDP resolution used : 3840x2160

Bug detailed description:
-----------------------------
3840 x 2160 resolution eDP panel is not lighting up in SKL-MBL. 

Isolation:
----------------------------
But it getting detected in kernel. Attached the xrandr output( xrandr.log)

Reproduce steps:
---------------------------- 

1. Boot the SKL with the above mentioned config with 3840x2160 eDP.
2. observe the eDP failure.
Comment 1 Vijayakannan Ayyathurai 2015-06-22 06:55:55 UTC
Created attachment 116643 [details]
dmesg_4840x2160.log
Comment 2 Jani Nikula 2015-06-22 13:35:29 UTC
[    5.471830] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1.bin failed with error -2
[    5.471980] [drm:i915_firmware_load_error_print [i915]] *ERROR* failed to load firmware i915/skl_dmc_ver1.bin (0)

Please ensure you have dmc firmware from [1] properly installed.

[1] https://01.org/linuxgraphics/downloads
Comment 3 Vijayakannan Ayyathurai 2015-06-30 13:21:50 UTC
Finding similar issue when loading the DUT with skl_dmc_ver1_18.bin. Attached the dmesg for your reference.

Vijay
Comment 4 Vijayakannan Ayyathurai 2015-06-30 13:23:29 UTC
Created attachment 116820 [details]
dmesg_dmc_loaded.log
Comment 5 Jani Nikula 2015-06-30 13:39:07 UTC
(In reply to vijayakannan from comment #3)
> Finding similar issue when loading the DUT with skl_dmc_ver1_18.bin.
> Attached the dmesg for your reference.

Please reproduce using an upstream kernel, e.g. drm-intel-nightly branch of http://cgit.freedesktop.org/drm-intel
Comment 6 Paulo Zanoni 2015-08-04 14:12:04 UTC
Please try to boot with i915.edp_vswing=1 or with i915.edp_vswing=2 as Kernel parameters. Do any of these solve your problem?
Comment 7 cprigent 2015-08-04 15:54:18 UTC
Bug scrub: looks like the same as #91269.
Let's Vijay answer to the question to confirm it.
Comment 8 Vijayakannan Ayyathurai 2015-08-05 09:36:23 UTC
Created attachment 117539 [details]
eDP_Resolution_3840x2160_xorg

i915.edp_vswing=1 or with i915.edp_vswing=2 is not solving this problem. Added the dmesg in the Related Jira bug. Adding Xorg.log in for your reference.
Comment 9 Jani Nikula 2015-08-13 07:04:41 UTC
(In reply to cprigent from comment #7)
> Bug scrub: looks like the same as #91269.
> Let's Vijay answer to the question to confirm it.

Christophe, please reference other bugs like this: bug 91269 so they get linked automagically. Thanks.
Comment 10 Rodrigo Vivi 2015-08-20 19:53:15 UTC
Created attachment 117827 [details] [review]
ddi translation

Could you please check if this patch helps?
Comment 11 Vijayakannan Ayyathurai 2015-08-27 10:14:05 UTC
Hi Rodrigo,
Sorry for the delay. Issue is same with this patch. 

Thanks,
Vijay
Comment 12 Jesse Barnes 2016-01-11 17:41:34 UTC
Does this still occur?  Can you attach the dmesg as well from when the failure occurs?  See https://01.org/linuxgraphics/documentation/how-report-bugs
Comment 13 Ville Syrjala 2016-05-25 19:48:38 UTC
Can you test again with the latest drm-intel-nightly? I suspect this is due to cdclk being too low, but with the latest nightly we can now bump up the clock speed correctly. If it still fails, please attach full dmesg with the drm.debug=0xe option passed to the kernel.
Comment 14 maria guadalupe 2016-06-02 20:16:56 UTC
The issue is not seen in SKL-Y platform with this configuration 

Software information 
============================================ 
Kernel version              	: 4.6.0-drm-intel-nightly-ww23-commit-fb023a2+ 
Linux distribution          	: Ubuntu 16.04 LTS 
Architecture                	: 64-bit 
Mesa version                	: 11.2.2 (git-3a9f628 
xf86-video-intel version    	: 2.99.917 
Xorg-Xserver version        	: 1.18.3 
DRM version                 	: 2.4.68 
VAAPI version               	: Intel i965 driver for Intel(R) Skylake - 1.7.0 
Cairo version               	: 1.15.2 
Intel GPU Tools version       	: Tag [intel-gpu-tools-1.14-348-g303b380] / Commit [303b380] 
Kernel driver in use        	: i915 
Hardware acceleration        	: Enabled 
Bios revision               	: 106.4 
KSC revision                	: 1.20 


 Hardware information 
============================================ 
Platform                     	: SKL-Y to KBL (RVP3) 
Motherboard model            	: Skylake Client platform 
Motherboard type             	: Skylake Y LPDDR3 RVP3 Laptop 
Motherboard manufacturer     	: Intel Corporation 
CPU family                   	: <OUT OF SPEC> 
CPU information              	: Intel(R) Core(TM) m5-6Y57 CPU @ 1.10GHz 
GPU Card                     	: Intel Corporation Sky Lake Integrated Graphics (rev 07) (prog-if 00 [VGA controller]) 
Memory ram                   	: 4 GB 
Maximum memory ram allowed   	: 16 GB 
CPU's number             	: 4 

 Firmwares information 
============================================ 
DMC fw loaded                	: yes 
DMC version                	: 1.26 


kernel configuration
=====================
commit fb023a2062df06c9e097e1f8f2bcf252194b9413
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon May 30 10:46:14 2016 +0200

    drm-intel-nightly: 2016y-05m-30d-08h-45m-53s UTC integration manifest


Kernel version : 4.6.0

eDP model
================
Samsung 4K eDP 1.3 panel 15.6" 3840x2160 non touch (SKL BOM#3) 

attachments
================
dmesg.log
xrandr.log
Comment 15 maria guadalupe 2016-06-02 20:18:57 UTC
Created attachment 124287 [details]
xrandr.log
Comment 16 maria guadalupe 2016-06-02 20:19:24 UTC
Created attachment 124288 [details]
dmesg.log
Comment 17 Jani Nikula 2016-06-17 16:29:26 UTC
(In reply to maria guadalupe from comment #14)
> The issue is not seen in SKL-Y platform with this configuration 

Thanks, closing. Please reopen if the problem persists with latest kernels.
Comment 18 cprigent 2016-09-07 11:29:59 UTC
I can't double confirm as my SKL as no eDP.
Closed. Please re-open if needed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.