Bug 91076 - Repeated GPU hangs with Linux 4.1 on i5-5300U graphics
Summary: Repeated GPU hangs with Linux 4.1 on i5-5300U graphics
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-23 19:02 UTC by Michael Marley
Modified: 2017-07-24 22:46 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Contents of /sys/class/drm/card0/error (2.66 MB, text/plain)
2015-06-23 19:02 UTC, Michael Marley
no flags Details
output of lspci (8.71 KB, text/plain)
2015-06-23 19:03 UTC, Michael Marley
no flags Details
output of dmesg (58.16 KB, text/plain)
2015-06-23 19:03 UTC, Michael Marley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Marley 2015-06-23 19:02:03 UTC
Created attachment 116675 [details]
Contents of /sys/class/drm/card0/error

Since upgrading my Intel NUC5i5MYHE with the Core i5-5300U CPU from Linux kernel 4.0.5 to Linux kernel 4.1.0, I now get repeated GPU hangs about every 6 seconds starting immediately after boot.  I have attached both the dmesg output showing the hang messages and the contents of /sys/class/drm/card0/error, as requested by the first hang message.

This is a headless system and does not have Xorg installed or running (only the framebuffer console is active).  The "monitor" attached is a dummy display simulator dongle attached to a Mini DisplayPort to HDMI connector and not a real monitor.  Plugging in a real (DVI) monitor using another adapter yields the same hangs, as does plugging in no monitor at all.  While the real monitor is attached, I can detect the GPU hangs as jerkiness in display updates, but the console is still usable.
Comment 1 Michael Marley 2015-06-23 19:03:38 UTC
Created attachment 116676 [details]
output of lspci
Comment 2 Michael Marley 2015-06-23 19:03:53 UTC
Created attachment 116677 [details]
output of dmesg
Comment 3 Chris Wilson 2015-06-24 06:57:31 UTC
Try intel_iommu=igfx_off
Comment 4 Michael Marley 2015-06-24 09:25:35 UTC
I replaced the "intel_iommu=on" I had on the kernel command line with "intel_iommu=on,igfx_off" and now the hangs are gone.  Thanks!
Comment 5 Chris Wilson 2015-06-24 09:41:16 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.