Bug 91077 - dri2_glx.c:1186: undefined reference to `loader_open_device'
Summary: dri2_glx.c:1186: undefined reference to `loader_open_device'
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-06-23 19:05 UTC by Vinson Lee
Modified: 2015-06-24 13:35 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2015-06-23 19:05:04 UTC
mesa: 3fa9bb81ec8b21f472de32e08d0caf917239da08 (master 10.7.0-devel)

324ee9b391ea2db4b74709d30a131e79055bf071 is the first bad commit
commit 324ee9b391ea2db4b74709d30a131e79055bf071
Author: Derek Foreman <derekf@osg.samsung.com>
Date:   Wed Jun 17 11:28:50 2015 -0500

    glx: Use loader_open_device() helper
    
    We've moved the open with CLOEXEC idiom into a helper function, so
    call it instead of duplicating the code here.
    
    Signed-off-by: Derek Foreman <derekf@osg.samsung.com>
    Reviewed-by: Kristian Høgsberg <krh@bitplanet.net>
    Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>

:040000 040000 57dcc9a36cb72627a1e91340f099355200434adb 180705d900106982a31274f4a068c8bc39526a7c M	src
bisect run success
Comment 1 Derek Foreman 2015-06-23 19:21:16 UTC
What configure options are you using?

Can you attach a build log?

Do you have any local changes?

Having a hard time figuring this out, I can't reproduce it here, and dri2_glx.c uses other functions from loader.c so there should at least be a pile of other undefined references.

Can you do a make clean and try again?  Perhaps you have some kind of timestamp issue that led to a partial rebuild...
Comment 2 Vinson Lee 2015-06-23 21:27:04 UTC
Clean checkout and build on CentOS 6.

$ ./autogen.sh --disable-dri3 --enable-sysfs --with-dri-drivers=swrast --with-gallium-drivers=
$ make
[...]
  CC     XF86dri.lo
dri_common.c: In function ‘dri2_convert_glx_attribs’:
dri_common.c:469: warning: ‘profile’ may be used uninitialized in this function
  CCLD   libglx.la
  CCLD   libGL.la
./.libs/libglx.a(dri2_glx.o): In function `dri2CreateScreen':
src/glx/dri2_glx.c:1186: undefined reference to `loader_open_device'
collect2: ld returned 1 exit status
Comment 3 Julien Isorce 2015-06-23 21:48:51 UTC
Hi, I just sent a patch on the mailing list as I encountered the same problem on darwin.
Comment 4 Emil Velikov 2015-06-24 13:35:32 UTC
I do wonder if/when we can fold some of the conditional compilation mayhem in the loader, but until then I've pushed Julien's patch.

Thanks for the prompt fix !


bug/show.html.tmpl processed on Mar 27, 2017 at 08:31:36.
(provided by the Example extension).