Bug 91084 - RadeonSI crash while playing World Of Tanks
Summary: RadeonSI crash while playing World Of Tanks
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-24 12:34 UTC by Eduards Bezverhijs
Modified: 2015-08-07 18:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
syslog (278.39 KB, text/plain)
2015-06-24 12:35 UTC, Eduards Bezverhijs
no flags Details
Photo of bug happening on screen (662.18 KB, image/jpeg)
2015-06-24 12:36 UTC, Eduards Bezverhijs
no flags Details
Package versions / lspci (8.19 KB, text/plain)
2015-06-24 12:37 UTC, Eduards Bezverhijs
no flags Details
Xorg.log (79.88 KB, text/plain)
2015-06-24 12:40 UTC, Eduards Bezverhijs
no flags Details
syslog (last 500 lines) (57.97 KB, text/plain)
2015-07-05 18:53 UTC, Eduards Bezverhijs
no flags Details
Xorg.log with error at the end (63.94 KB, text/plain)
2015-07-05 18:54 UTC, Eduards Bezverhijs
no flags Details
R600_DEBUG=fs,vs,gs,ps,cs,vm (this one has interesting info at the end) (434.29 KB, text/plain)
2015-07-05 18:56 UTC, Eduards Bezverhijs
no flags Details
A bit different crashlog from archlinux (mesa/radeon git from 11.07.2015) (23.78 KB, text/plain)
2015-07-12 11:48 UTC, Eduards Bezverhijs
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduards Bezverhijs 2015-06-24 12:34:37 UTC
Computer freezes completely however I can access it via the ssh.
Versions are in the files.

This is with Ubuntu 14.04 using liquorix kernel and this is the first time I can actually ssh into the machine after crash.
Previously tried with Ubuntu 15.04 using kernel 4.1/3.13/3.19/4.0.x all of them crash completely.

Versions/syslog/etc. are in the attachments.

Please ask if You need more info.
Comment 1 Eduards Bezverhijs 2015-06-24 12:35:34 UTC
Created attachment 116691 [details]
syslog
Comment 2 Eduards Bezverhijs 2015-06-24 12:36:36 UTC
Created attachment 116692 [details]
Photo of bug happening on screen
Comment 3 Eduards Bezverhijs 2015-06-24 12:37:45 UTC
Created attachment 116693 [details]
Package versions / lspci
Comment 4 Eduards Bezverhijs 2015-06-24 12:40:38 UTC
Created attachment 116694 [details]
Xorg.log
Comment 5 Michel Dänzer 2015-06-25 01:25:59 UTC
If you're using the Gallium nine state tracker, this may be a duplicate of bug 89713.
Comment 6 Eduards Bezverhijs 2015-06-25 08:46:07 UTC
Well, might be, once I tried posting to that bug as well, but with rather incomplete info, now I have a lot more and it didn't look like that bug, albeit the reason for bug might be the same.

Suggest plz how to proceed further, repost everything to that bug, or ... ?
Comment 7 Eduards Bezverhijs 2015-07-05 10:12:24 UTC
Hi,

I tried to experiment even further, what seems to be odd is that after about 7 minutes it will crash, I don't have to do anything in the game - 7 minutes pass and it hangs.
I tried to play simple training area, just waited till training map loaded up, I didn't even move the tank or mouse or anything (game was not even active window), started stopwatch and after 7 and 2 seconds it started to draw crazy lines and 7:07 it crashed completely. Of course this is not in any way scientific test :)

It seems quite odd that always 7 minutes and crash. I'm just trying to think, 7 mins, 420 secs, 25200 frames @ 60 fps (which I can't reach).

Will try to do more testing with debugging enabled.
Comment 8 Eduards Bezverhijs 2015-07-05 18:52:56 UTC
Ok, I installed -dbg packages for mesa/radeon, didn't and had no luck using gdb (or I don't know how to use it to debug radeon/mesa drivers), but I had luck getting some debug out of R600_DEBUG.

Please note "radeon: The kernel rejected CS, see dmesg for more information." and "radeon: Failed to deallocate virtual address for buffer:" in the R600_DEBUG.txt file.

I had 400MB of syslog filled with errors, I took just last 500 lines to upload here.

Hope this will help a bit more with solving the issue.
Please advise what can I do more.
Comment 9 Eduards Bezverhijs 2015-07-05 18:53:33 UTC
Created attachment 116962 [details]
syslog (last 500 lines)
Comment 10 Eduards Bezverhijs 2015-07-05 18:54:17 UTC
Created attachment 116963 [details]
Xorg.log with error at the end
Comment 11 Eduards Bezverhijs 2015-07-05 18:56:16 UTC
Created attachment 116964 [details]
R600_DEBUG=fs,vs,gs,ps,cs,vm (this one has interesting info at the end)
Comment 12 Eduards Bezverhijs 2015-07-12 11:48:11 UTC
Created attachment 117071 [details]
A bit different crashlog from archlinux (mesa/radeon git from 11.07.2015)
Comment 13 Eduards Bezverhijs 2015-08-01 21:35:50 UTC
Hi,

I'm glad to report that today I tried playing WOT with latest mesa/radeon and it didn't crash for at least 3 hrs (wine 1.7.44-nine, gallium nine, oibaf ppa).
Package versions are as follows: all mesa package versions are 10.7~git1507310730.7830e4~gd~t, radeon driver package version is 7.5.99+git1507301931.09c7cd~gd~t.

Not sure if this helped or not, but one thing that I had to change (because I had to free some space temporarily) was to move radeon card to pcie x8 slot, after a week or so I'll move radeon back to x16 slot and will test again.

regards
Mjasnik
Comment 14 Eduards Bezverhijs 2015-08-07 18:56:31 UTC
Hi,

so I moved back radeon to x16 slot and it works. I played like 2-3 hrs in a row and no crash, it played quite well, except some graphical glitches for shadow and some crappy graphics for couple of seconds at the start of the battle, but the rest is very good.

So I guess this problem is gone.

As I finally got this working, I didn't update packages, I'll do that later, but my bet is that all will be working.

regards
Mjasnik


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.