Bug 91097 - Pointer sometimes moves before hard click on trackpad
Summary: Pointer sometimes moves before hard click on trackpad
Status: RESOLVED INVALID
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
: 94861 (view as bug list)
Depends on:
Blocks: 94861 99268
  Show dependency treegraph
 
Reported: 2015-06-24 19:53 UTC by Wade Berrier
Modified: 2017-10-11 03:10 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
attempted sloppy hard clicks on paint app (5.92 KB, text/plain)
2015-06-24 19:55 UTC, Wade Berrier
Details
single hard click recording (12.09 KB, text/plain)
2015-06-24 19:56 UTC, Wade Berrier
Details
multiple hard clicks recording (144.84 KB, text/plain)
2015-06-24 19:56 UTC, Wade Berrier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wade Berrier 2015-06-24 19:53:54 UTC
Sometimes when doing a "sloppy" hard click on the trackpad, the pointer will move enough so that the intended target is not clicked.  (A sloppy click being where your finger rolls down as it's clicking).

This was greatly improved in the 0.18 release, but there are additional improvements that can be made.

See https://bugzilla.redhat.com/show_bug.cgi?id=1230441 for related information.


See the attached image for a better description of what is going on.  In the image, it was intended that the dots line up horizontally.  For the dots that don't line up, that's because the pointer moved before the click was registered.
Comment 1 Wade Berrier 2015-06-24 19:55:07 UTC
Created attachment 116699 [details]
attempted sloppy hard clicks on paint app
Comment 2 Wade Berrier 2015-06-24 19:56:27 UTC
Created attachment 116700 [details]
single hard click recording
Comment 3 Wade Berrier 2015-06-24 19:56:54 UTC
Created attachment 116701 [details]
multiple hard clicks recording
Comment 4 Peter Hutterer 2015-06-25 01:44:12 UTC
for the archives, we need to track pressure changes to predict this (not possible on all touchpads)
Comment 5 Peter Hutterer 2016-01-08 05:50:23 UTC
No-one is currently working on this, anyone to stumble across this bug please feel free to take it.
Comment 6 Peter Hutterer 2016-05-06 05:22:17 UTC
Small update: I was testing this on an apple laptop recently and afaict they have a bottom button area (hidden of course since they use clickfinger to actually click) where this motion gets discarded. This could be a solution for libinput, where clickfinger is enabled, the lower area of the touchpad could be less sensitive to movements for a short timeout after finger down.
Comment 7 Peter Hutterer 2017-05-19 05:03:52 UTC
*** Bug 94861 has been marked as a duplicate of this bug. ***
Comment 8 Peter Hutterer 2017-08-28 04:51:40 UTC
can you try this with libinput master please? we now have touch pressure detection so we should detect a touch a bit later than before. This may help with this bug (but it's not a guarantee)
Comment 9 Peter Hutterer 2017-10-11 03:10:27 UTC
needinfo for 6+ weeks, and I think it may have improved with 1.8 anyway. let's re-open this if necessary


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.