Bug 91101 - [softpipe] piglit glsl-1.50@execution@geometry@max-input-components regression
Summary: [softpipe] piglit glsl-1.50@execution@geometry@max-input-components regression
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-06-25 00:25 UTC by Vinson Lee
Modified: 2016-03-04 20:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2015-06-25 00:25:56 UTC
mesa: e31bce4041122cd00712b60b4dc1eae6486f6579 (master 10.7.0-devel)

$ ./bin/shader_runner tests/spec/glsl-1.50/execution/geometry/max-input-components.shader_test -auto
shader_runner: tgsi/tgsi_exec.c:1265: fetch_src_file_channel: Assertion `pos < 6 * 32' failed.
Aborted (core dumped)

(gdb) bt
#0  0x00007fc5c4efa267 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x00007fc5c4efbeca in __GI_abort () at abort.c:89
#2  0x00007fc5c4ef303d in __assert_fail_base (fmt=0x7fc5c5055028 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", 
    assertion=assertion@entry=0x7fc5bfd54891 "pos < 6 * 32", file=file@entry=0x7fc5bfd5484f "tgsi/tgsi_exec.c", line=line@entry=1265, 
    function=function@entry=0x7fc5bfd55230 <__PRETTY_FUNCTION__.7359> "fetch_src_file_channel") at assert.c:92
#3  0x00007fc5c4ef30f2 in __GI___assert_fail (assertion=assertion@entry=0x7fc5bfd54891 "pos < 6 * 32", 
    file=file@entry=0x7fc5bfd5484f "tgsi/tgsi_exec.c", line=line@entry=1265, 
    function=function@entry=0x7fc5bfd55230 <__PRETTY_FUNCTION__.7359> "fetch_src_file_channel") at assert.c:101
#4  0x00007fc5bfc0b9f7 in fetch_src_file_channel (mach=mach@entry=0x7fc5bdd36010, file=<optimized out>, swizzle=<optimized out>, 
    index=index@entry=0x7ffd29c9e400, index2D=index2D@entry=0x7ffd29c9e410, chan=chan@entry=0x7ffd29c9e4d0, chan_index=0) at tgsi/tgsi_exec.c:1265
#5  0x00007fc5bfc0c12d in fetch_source_d (mach=mach@entry=0x7fc5bdd36010, chan=chan@entry=0x7ffd29c9e4d0, reg=reg@entry=0x25bcf90, 
    chan_index=chan_index@entry=0, src_datatype=TGSI_EXEC_DATA_FLOAT) at tgsi/tgsi_exec.c:1474
#6  0x00007fc5bfc0c2d2 in fetch_source (mach=mach@entry=0x7fc5bdd36010, chan=chan@entry=0x7ffd29c9e4d0, reg=reg@entry=0x25bcf90, 
    chan_index=chan_index@entry=0, src_datatype=src_datatype@entry=TGSI_EXEC_DATA_FLOAT) at tgsi/tgsi_exec.c:1490
#7  0x00007fc5bfc0cdb8 in exec_vector_unary (mach=0x7fc5bdd36010, inst=inst@entry=0x25bcf60, op=op@entry=0x7fc5bfc09880 <micro_mov>, 
    src_datatype=src_datatype@entry=TGSI_EXEC_DATA_FLOAT, dst_datatype=TGSI_EXEC_DATA_UINT) at tgsi/tgsi_exec.c:2768
#8  0x00007fc5bfc117e7 in exec_instruction (mach=mach@entry=0x7fc5bdd36010, inst=0x25bcf60, pc=pc@entry=0x7ffd29c9e734) at tgsi/tgsi_exec.c:4162
#9  0x00007fc5bfc13827 in tgsi_exec_machine_run (mach=mach@entry=0x7fc5bdd36010) at tgsi/tgsi_exec.c:5151
#10 0x00007fc5bfbdc615 in tgsi_gs_run (shader=<optimized out>, input_primitives=<optimized out>) at draw/draw_gs.c:216
#11 0x00007fc5bfbdc6f0 in gs_flush (shader=0x25a3a20) at draw/draw_gs.c:415
#12 0x00007fc5bfbdc9b8 in gs_tri_adj (shader=0x25a3a20, i0=<optimized out>, i1=<optimized out>, i2=<optimized out>, i3=<optimized out>, 
    i4=<optimized out>, i5=5) at draw/draw_gs.c:517
#13 0x00007fc5bfbdcd06 in gs_run (input_prims=<optimized out>, input_prims=<optimized out>, input_prims=<optimized out>, input_prims=<optimized out>, 
    input_verts=<optimized out>, output_prims=<optimized out>, output_verts=<optimized out>, gs=<optimized out>) at draw/draw_decompose_tmp.h:342
#14 draw_geometry_shader_run (shader=0x25a3a20, constants=0x46f5, constants_size=0x6, input_verts=0x1, input_prim=0x7ffd29c9e9e0, input_info=0xb, 
    output_verts=0x7ffd29c9e8c0, output_prims=0x7ffd29c9e900) at draw/draw_gs.c:638
#15 0x00007fc5bfbee7a7 in fetch_pipeline_generic (middle=0x1e02080, fetch_info=0x46f5, fetch_info@entry=0x7ffd29c9e9c0, in_prim_info=0x7ffd29c9e9e0)
    at draw/draw_pt_fetch_shade_pipeline.c:290
#16 0x00007fc5bfbeec16 in fetch_pipeline_linear_run (middle=<optimized out>, start=<optimized out>, count=6, prim_flags=<optimized out>)
    at draw/draw_pt_fetch_shade_pipeline.c:416
#17 0x00007fc5bfbf4149 in vsplit_segment_simple_linear (vsplit=0x1eb6c40, vsplit=0x1eb6c40, icount=6, istart=0, flags=0)
    at draw/draw_pt_vsplit_tmp.h:240
#18 vsplit_run_linear (frontend=0x1eb6c40, start=0, count=6) at draw/draw_split_tmp.h:60
#19 0x00007fc5bfbebb15 in draw_pt_arrays (draw=draw@entry=0x1df9d80, prim=12, start=0, count=count@entry=6) at draw/draw_pt.c:149
#20 0x00007fc5bfbec143 in draw_vbo (draw=draw@entry=0x1df9d80, info=0x7ffd29c9eb10, info@entry=0x7ffd29c9ec10) at draw/draw_pt.c:564
#21 0x00007fc5bfc8ff5a in softpipe_draw_vbo (pipe=0x1dedf10, info=0x7ffd29c9ec10) at sp_draw_arrays.c:147
#22 0x00007fc5bfadbec0 in st_draw_vbo (ctx=<optimized out>, prims=<optimized out>, nr_prims=<optimized out>, ib=0x0, 
    index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0, indirect=0x0) at state_tracker/st_draw.c:286
#23 0x00007fc5bfaa4de3 in vbo_draw_arrays (ctx=0x7fc5c5a5d010, mode=12, start=0, count=6, numInstances=1, baseInstance=0) at vbo/vbo_exec_array.c:645
#24 0x00007fc5c553b103 in stub_glDrawArrays (mode=12, first=0, count=6) at piglit/tests/util/piglit-dispatch-gen.c:11317
#25 0x000000000040a995 in piglit_display () at piglit/tests/shaders/shader_runner.c:2397
#26 0x00007fc5c55c6f8e in run_test (gl_fw=0x1dda010, argc=2, argv=0x7ffd29c9f0a8)
    at piglit/tests/util/piglit-framework-gl/piglit_winsys_framework.c:79
#27 0x00007fc5c55ab999 in piglit_gl_test_run (argc=2, argv=0x7ffd29c9f0a8, config=0x7ffd29c9ef60)
    at piglit/tests/util/piglit-framework-gl.c:191
#28 0x00000000004050b0 in main (argc=2, argv=0x7ffd29c9f0a8) at piglit/tests/shaders/shader_runner.c:54


7ffc1fb928268f8493e88d45e9a006208d05f0f6 is the first bad commit
commit 7ffc1fb928268f8493e88d45e9a006208d05f0f6
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Thu Mar 19 23:27:10 2015 +0100

    gallium: bump shader input and output limits
    
    Reviewed-by: Roland Scheidegger <sroland@vmware.com>
    Signed-off-by: Marek Olšák <marek.olsak@amd.com>

:040000 040000 c8ba9549231eff63c36137320a597d586a53298a a53d5640b434fc002eca189ffcb19aec79e1755a M	src
bisect run success
Comment 1 Juan A. Suarez 2016-03-04 11:20:12 UTC
Seems to be fixed in master (11.2-branchpoint-233-g9ec2467)

Commit fixing it is:

commit 77a78c65f80323059d892c501ca551ccf324b17d
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Thu Jun 25 00:56:32 2015 +0200

    softpipe,llvmpipe: fix PIPE_SHADER_CAP_MAX_INPUTS value
    
    PIPE_MAX_SHADER_INPUTS was recently bumped to 80 because of tessellation.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=91099
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=91101
    
    Reviewed-by: Brian Paul <brianp@vmware.com>
    Reviewed-by: Roland Scheidegger <sroland@vmware.com>

:040000 040000 0fb06b2a98f641dcb6f0d248d406cbbc0665242f 4b9c0fe3ab1bd95b8a9b146c9ce3c440d11901d3 M	src


bug/show.html.tmpl processed on Feb 19, 2017 at 11:47:02.
(provided by the Example extension).