Bug 91152 - On kernel 4.1.0 with HD Graphics 5500, GPU hangs at boot time before Xorg started
Summary: On kernel 4.1.0 with HD Graphics 5500, GPU hangs at boot time before Xorg sta...
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-29 22:12 UTC by Sami Liedes
Modified: 2017-07-24 22:46 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/crad0/error, bzip2 compressed (141.00 KB, text/plain)
2015-06-29 22:12 UTC, Sami Liedes
no flags Details
dmesg (58.99 KB, text/plain)
2015-06-29 22:13 UTC, Sami Liedes
no flags Details
/sys/class/drm/card0/error with i915.enable_execlists=0; bzip2 compressed (156.75 KB, application/x-bzip)
2015-06-30 20:16 UTC, Sami Liedes
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sami Liedes 2015-06-29 22:12:27 UTC
Created attachment 116807 [details]
/sys/class/drm/crad0/error, bzip2 compressed

On a Dell XPS 13 9343 laptop with HD Graphics 5500, kernel 4.1.0 reports a GPU hang at boot, even without starting Xorg. On kernel 4.0.6 this does not happen and X works. Happens with 100% reproducibility over 5-10 boot attempts.

Booting the kernel to rescue mode (and thus not starting Xorg), I used the text console (which still works) to extract dmesg and /sys/class/drm/card0/error; these are attached. At that point I'm already getting GPU hung messages.

(Note that the dmesg capture shows too old firmware for iwlwifi. Suspecting that that might have caused global weirdness, just to be sure I also verified that installing newer iwlwifi firmware doesn't fix the GPU hang.)

    7.725370] [drm] GPU HANG: ecode 8:0:0x00dfffff, reason: Ring hung, action: reset
[    7.725398] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[    7.725431] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[    7.725461] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[    7.725494] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[    7.725525] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[    7.726654] drm/i915: Resetting chip after gpu hang
[    7.726888] dmar: DRHD: handling fault status reg 2
[    7.726923] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr 1694000 
               DMAR:[fault reason 23] Unknown
[   13.729606] [drm] stuck on render ring
[   13.732013] [drm] GPU HANG: ecode 8:0:0xfffffffe, reason: Ring hung, action: reset
[   13.733581] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[   13.735190] drm/i915: Resetting chip after gpu hang
[   19.734356] [drm] stuck on render ring
[   19.736707] [drm] GPU HANG: ecode 8:0:0x00dfffff, reason: Ring hung, action: reset
[   19.740359] drm/i915: Resetting chip after gpu hang
Comment 1 Sami Liedes 2015-06-29 22:13:06 UTC
Created attachment 116808 [details]
dmesg
Comment 2 Chris Wilson 2015-06-30 08:12:50 UTC
Can you try i915.enable_execlists=0 first and then intel_iommu=igfx_off?
Comment 3 Sami Liedes 2015-06-30 20:16:50 UTC
Created attachment 116828 [details]
/sys/class/drm/card0/error with i915.enable_execlists=0; bzip2 compressed

With i915.enable_execlists=0, I get a single "[drm] stuck on render ring"/GPU hang at boot. With intel_iommu=igfx_off, I see no GPU hangs and Xorg starts.

enable_execlists=0 case:

[    7.723370] [drm] stuck on render ring
[    7.724052] [drm] GPU HANG: ecode 8:0:0x00dfffff, reason: Ring hung, action: reset
[    7.724081] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[    7.724113] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[    7.724145] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[    7.724177] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[    7.724209] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[    7.725348] drm/i915: Resetting chip after gpu hang

Contents of /sys/class/drm/card0/error with enable_execlists=0 attached.
Comment 4 Chris Wilson 2015-07-01 07:43:15 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.