Bug 91158 - Piglit regression: spec/ARB_texture_multisample/arb_texture_multisample-sample-mask-execution
Summary: Piglit regression: spec/ARB_texture_multisample/arb_texture_multisample-sampl...
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.6
Hardware: All Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-30 12:19 UTC by Svyatoslav Pankratov
Modified: 2017-02-10 22:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Svyatoslav Pankratov 2015-06-30 12:19:38 UTC
Piglit test spec/ARB_texture_multisample/arb_texture_multisample-sample-mask-execution starts fail after adding XRGB8888 format to intel_screen_make_configs to Mesa 10.6 (commit 28090b30dd6b5977de085f48c620574214b6b4ba)

spec/ARB_texture_multisample/arb_texture_multisample-sample-mask-execution fails in src/mesa/main/blit.c: _mesa_blit_framebuffer() with bad src/dst multisample pixel formats. But in intel driver can handle both RGB and RGBA src/dst pixel formats. 

Adding additional checks to compatible_resolve_formats function can solve this regression, but...
+   if ((readFormat == GL_RGB8 || readFormat == GL_RGBA8) &&   
+       (drawFormat == GL_RGB8 || drawFormat == GL_RGBA8))       
+       return GL_TRUE;                                          
+                                                             
+                                                                

But some tests from OGLconform fails too due they trying to check color with alpha. And this fix isn't valid for it.

Reverting 28090b30dd6b5977de085f48c620574214b6b4ba may broke Weston.
Comment 1 Iago Toral 2015-07-13 13:49:31 UTC
I can't reproduce this with current master (de5c2b6f2b5) on IvyBridge:

$ bin/arb_texture_multisample-sample-mask-execution -auto -fbo
Using classic MSAA renderbuffer
PIGLIT: {"result": "pass" }

$ bin/arb_texture_multisample-sample-mask-execution -tex -auto -fbo
Using GL_TEXTURE_2D_MULTISAMPLE
PIGLIT: {"result": "pass" }

FWIW, compatible_resolve_formats() is returning TRUE for me on the first check:

if (_mesa_get_srgb_format_linear(readRb->Format) ==
    _mesa_get_srgb_format_linear(drawRb->Format)) {
   return GL_TRUE;
}

where:

readRb->format == drawRb->Format == MESA_FORMAT_R8G8B8A8_UNORM

Could it be that the regression is specific to a particular hardware platform or could this be already fixed in master?
Comment 2 Matt Turner 2016-11-03 21:29:08 UTC
I cannot reproduce on IVB or HSW.

Please reopen if you can still reproduce.
Comment 3 Annie 2017-02-10 22:39:17 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.