Bug 9135 - 0.21 fails make check
0.21 fails make check
Status: RESOLVED FIXED
Product: pkg-config
Classification: Unclassified
Component: src
unspecified
x86 (IA32) Linux (All)
: low minor
Assigned To: Tollef Fog Heen
:
: 13530 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 22:33 UTC by J. Scott Berg
Modified: 2012-05-21 21:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Fix for incorrect tests (829 bytes, patch)
2006-11-25 14:47 UTC, Matthew Burgess
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description J. Scott Berg 2006-11-22 22:33:30 UTC
The relevant bit:

make[2]: Entering directory `/home/jsberg/pkg-config-0.21/check'
PASS: check-cflags
PASS: check-libs
PASS: check-define-variable
PASS: check-libs-private
../pkg-config --cflags requires-test :
'-I/requires-test/include -I/private-dep/include -I/public-dep/include' !=
'-I/requires-test/include -I/public-dep/include'
FAIL: check-requires-private
PASS: check-includedir
===================
1 of 6 tests failed
===================
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/home/jsberg/pkg-config-0.21/check'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/jsberg/pkg-config-0.21/check'
make: *** [check-recursive] Error 1
Comment 1 Matthew Burgess 2006-11-25 14:47:42 UTC
Created attachment 7899 [details] [review]
Fix for incorrect tests

FWIW, I'm hitting the same bug too.  The attached patch fixes the problem for
me, though I've assumed that it's the tests that are incorrect, rather than the
output from pkg-config itself.
Comment 2 Dan Nicholson 2012-05-19 07:25:10 UTC
The results with -I/private-dep/include are indeed correct. I think this was fixed back in commit 9e5bcc26. The test suite has been passing on check-requires-private for some time now.
Comment 3 Dan Nicholson 2012-05-21 21:14:23 UTC
*** Bug 13530 has been marked as a duplicate of this bug. ***