Bug 91400 - Linux >= 3.19 graphics corruption and system crash when running as Xen dom0 with VT-d enabled on Intel Ironlake
Summary: Linux >= 3.19 graphics corruption and system crash when running as Xen dom0 w...
Status: CLOSED DUPLICATE of bug 90037
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on: 90037
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-20 10:35 UTC by Ting-Wei Lan
Modified: 2017-07-24 22:46 UTC (History)
1 user (show)

See Also:
i915 platform: ILK
i915 features:


Attachments
dmesg (626.25 KB, text/plain)
2015-07-20 10:35 UTC, Ting-Wei Lan
no flags Details
/sys/class/drm/card0/error (1.49 MB, text/plain)
2015-07-20 10:36 UTC, Ting-Wei Lan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2015-07-20 10:35:18 UTC
Created attachment 117251 [details]
dmesg

+++ This bug was initially created as a clone of Bug #90037 +++

When I use Linux >= 3.19 as the dom0 kernel of Xen, screen becomes unreadable after i915 driver is loaded. The screenshot is already posted as an attachment of another bug: https://bugs.freedesktop.org/attachment.cgi?id=115079. This screenshot is obtained when the system is in single user mode.

If it continues to boot into graphical mode, a lot of error messages are showed when the display manager is started. Screen output becomes more broken and the system crashes after several minutes.

VT-d is automatically enabled by Xen. If VT-d is manually disabled, there is no graphics problem and the system can run normally.

The bad commit showed by git bisect is https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=47591df

Please see the attached Xen dmesg, Linux dmesg and GPU crash dump.


CPU and GPU:
Intel Core i5 CPU 650 @ 3.20GHz
Intel Ironlake Desktop

Motherboard:
ASUSTeK Computer INC. P7H55D-M EVO

Software:
Xen 4.5.1
Linux 4.2-rc3
Xorg 1.17.2
Wayland 1.7.0
GDM 3.16.2
GNOME Shell 3.16.3


This problem was initially reported as here:
https://bugs.freedesktop.org/show_bug.cgi?id=90037

I sent a message to xen-devel and they thought it should be an i915 problem:
http://lists.xenproject.org/archives/html/xen-devel/2015-06/msg02236.html
http://lists.xenproject.org/archives/html/xen-devel/2015-06/msg02387.html

As I don't know how to fix the problem, I made a workaround in Xen:
http://lists.xenproject.org/archives/html/xen-devel/2015-07/msg03641.html

They also said it is an i915 problem:
http://lists.xenproject.org/archives/html/xen-devel/2015-07/msg03642.html
http://lists.xenproject.org/archives/html/xen-devel/2015-07/msg03723.html



A silimar problem also happens on Linux >= 3.7 without using Xen:
https://bugs.freedesktop.org/show_bug.cgi?id=91127

It was partially fixed in Linux 4.2-rc2:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8b572a4



It seems there are some common messages showed by Xen and Linux:

Messages showed by Xen with Linux 4.2-rc3 dom0:
(XEN) [VT-D]DMAR:[DMA Write] Request device [0000:00:02.0] fault addr 73fbff000, iommu reg = ffff82c000203000
(XEN) [VT-D]DMAR: reason 05 - PTE Write access is not set

Messages showed by Linux 4.2-rc2 when not using Xen:
DMAR: DMAR:[DMA Write] Request device [00:02.0] fault addr fde7c000
DMAR:[fault reason 05] PTE Write access is not set
Comment 1 Ting-Wei Lan 2015-07-20 10:36:31 UTC
Created attachment 117252 [details]
/sys/class/drm/card0/error
Comment 2 Jani Nikula 2015-08-20 13:55:38 UTC
Why is this not a dupe of bug 90037? Same bisect result and all.
Comment 3 Ileana 2016-04-19 10:57:47 UTC
No updates for a long time. Is this still an issue?
Comment 4 Ting-Wei Lan 2016-04-28 18:04:53 UTC
(In reply to Ileana from comment #3)
> No updates for a long time. Is this still an issue?

Yes, I still have to use the workaround I added to Xen 4.6 (iommu=no-igfx) to avoid this issue.

This bug was opened because I was afraid that the reopened bug would be ignored. As the original bug report got response, I am closing this bug as duplicate now.

*** This bug has been marked as a duplicate of bug 90037 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.