Bug 91458 - stuck on render ring (GPU HANG: ecode 8:0:0x85dffffb)
Summary: stuck on render ring (GPU HANG: ecode 8:0:0x85dffffb)
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-25 11:57 UTC by Matthias Nagel
Modified: 2017-07-24 22:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
full dmesg ouput (89.60 KB, text/plain)
2015-07-25 11:58 UTC, Matthias Nagel
no flags Details
lspic -v output (5.98 KB, text/plain)
2015-07-25 11:59 UTC, Matthias Nagel
no flags Details
/sys/class/drm/card0/error dump (2.73 MB, text/plain)
2015-07-25 12:00 UTC, Matthias Nagel
no flags Details
X.org log (20.47 KB, text/plain)
2015-07-25 12:00 UTC, Matthias Nagel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Nagel 2015-07-25 11:57:12 UTC
Might be the same as bug #91452, but in my case the crash does not occur randomly but reliably after at most 10min.

dmesg:

[  764.492100] [drm] stuck on render ring
[  764.493303] [drm] GPU HANG: ecode 8:0:0x85dffffb, in X [2336], reason: Ring hung, action: reset
[  764.493307] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  764.493310] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  764.493312] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  764.493315] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  764.493318] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  764.493490] ------------[ cut here ]------------
[  764.493501] WARNING: CPU: 0 PID: 6946 at drivers/gpu/drm/i915/intel_display.c:9603 intel_mmio_flip_work_func+0x58/0x2db()
[  764.493504] WARN_ON(__i915_wait_request(mmio_flip->req, crtc->reset_counter, false, NULL, NULL) != 0)
[  764.493506] Modules linked in:
[  764.493509]  iTCO_wdt iTCO_vendor_support lpc_ich btusb x86_pkg_temp_thermal mfd_core coretemp iwlmvm uvcvideo videobuf2_vmalloc videobuf2_memops iwlwifi videobuf2_core efivarfs
[  764.493528] CPU: 0 PID: 6946 Comm: kworker/0:2 Not tainted 4.0.5-gentoo #4
[  764.493531] Hardware name: LENOVO 20BTS08N00/20BTS08N00, BIOS N14ET26W (1.04 ) 01/23/2015
[  764.493537] Workqueue: events intel_mmio_flip_work_func
[  764.493540]  0000000000000009 ffff8801b452fce8 ffffffff8171454b 00000000000000f3
[  764.493545]  ffff8801b452fd38 ffff8801b452fd28 ffffffff810af085 ffff880241f1bf80
[  764.493550]  ffffffff813d08b6 ffff880243a118b0 ffff88024dc11d40 ffff88024dc16100
[  764.493555] Call Trace:
[  764.493564]  [<ffffffff8171454b>] dump_stack+0x45/0x57
[  764.493570]  [<ffffffff810af085>] warn_slowpath_common+0x97/0xb1
[  764.493575]  [<ffffffff813d08b6>] ? intel_mmio_flip_work_func+0x58/0x2db
[  764.493580]  [<ffffffff810af0e0>] warn_slowpath_fmt+0x41/0x43
[  764.493586]  [<ffffffff813d08b6>] intel_mmio_flip_work_func+0x58/0x2db
[  764.493591]  [<ffffffff810c7193>] ? dequeue_task+0x5e/0x65
[  764.493597]  [<ffffffff810bf4db>] process_one_work+0x19f/0x2b5
[  764.493602]  [<ffffffff810bfcc0>] worker_thread+0x258/0x34a
[  764.493608]  [<ffffffff810bfa68>] ? cancel_delayed_work_sync+0x10/0x10
[  764.493613]  [<ffffffff810c3838>] kthread+0xcd/0xd5
[  764.493619]  [<ffffffff810c376b>] ? kthread_create_on_node+0x16c/0x16c
[  764.493635]  [<ffffffff8171b148>] ret_from_fork+0x58/0x90
[  764.493640]  [<ffffffff810c376b>] ? kthread_create_on_node+0x16c/0x16c
[  764.493652] ---[ end trace edc274914fa5dbed ]---
[  764.497010] drm/i915: Resetting chip after gpu hang
[  764.499026] dmar: DRHD: handling fault status reg 2
[  764.499036] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr 18caf000 
DMAR:[fault reason 23] Unknown
[  764.608106] dmar: DRHD: handling fault status reg 2
[  764.608117] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr 18d15000 
DMAR:[fault reason 23] Unknown
[  770.495674] [drm] stuck on render ring
[  770.495681] [drm] stuck on blitter ring
[  770.496950] [drm] GPU HANG: ecode 8:0:0x86dffffd, in X [2336], reason: Ring hung, action: reset
[  770.497043] [drm:i915_context_is_banned] *ERROR* gpu hanging too fast, banning!
[  770.498661] drm/i915: Resetting chip after gpu hang
[  774.798652] dmar: DRHD: handling fault status reg 2
[  774.798659] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr a294000 
DMAR:[fault reason 23] Unknown
[  774.798851] dmar: DRHD: handling fault status reg 2
[  774.798855] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr a294000 
DMAR:[fault reason 23] Unknown
[  780.505674] [drm] stuck on render ring
[  780.506825] [drm] GPU HANG: ecode 8:0:0x00dfffff, in kwin [2472], reason: Ring hung, action: reset
[  780.509667] drm/i915: Resetting chip after gpu hang
[  780.519402] dmar: DRHD: handling fault status reg 3
[  780.519412] dmar: DMAR:[DMA Write] Request device [00:02.0] fault addr a294000 
DMAR:[fault reason 23] Unknown
[  786.511690] [drm] stuck on render ring
[  786.512923] [drm] GPU HANG: ecode 8:0:0x00dfffff, in kwin [2472], reason: Ring hung, action: reset
[  786.514674] drm/i915: Resetting chip after gpu hang
Comment 1 Matthias Nagel 2015-07-25 11:58:57 UTC
Created attachment 117369 [details]
full dmesg ouput
Comment 2 Matthias Nagel 2015-07-25 11:59:21 UTC
Created attachment 117370 [details]
lspic -v output
Comment 3 Matthias Nagel 2015-07-25 12:00:23 UTC
Created attachment 117371 [details]
/sys/class/drm/card0/error dump
Comment 4 Matthias Nagel 2015-07-25 12:00:44 UTC
Created attachment 117372 [details]
X.org log
Comment 5 Chris Wilson 2015-07-25 12:01:43 UTC

*** This bug has been marked as a duplicate of bug 89360 ***
Comment 6 Matthias Nagel 2015-07-25 12:09:47 UTC
I am not convinced that this is a duplicate of bug 89360. The description of bug 89360 says that the system freezes totally. This is *not* the case here. The X server does recover, continuous to run but disables acceleration afterwards.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.