Bug 91572 - PackageKit should not download packages in the background with network is limited (bandwidth reduced, or mobile data plan expensive)
Summary: PackageKit should not download packages in the background with network is lim...
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-06 08:56 UTC by Fabrice Bellet
Modified: 2018-08-21 15:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabrice Bellet 2015-08-06 08:56:32 UTC
I'm running PackageKit on Fedora 22, version 1.0.6. 

[bellet@gandi-2 ~]$ rpm -qa | grep -i PackageKit | sort
gnome-packagekit-3.16.0-1.fc22.x86_64
PackageKit-1.0.6-6.fc22.x86_64
PackageKit-cached-metadata-1.0.6-6.fc22.x86_64
PackageKit-command-not-found-1.0.6-6.fc22.x86_64
PackageKit-glib-1.0.6-6.fc22.x86_64
PackageKit-gstreamer-plugin-1.0.6-6.fc22.x86_64
PackageKit-gtk3-module-1.0.6-6.fc22.x86_64

I noticed that PackageKit downloads not only repos metadata, but also full rpm packages in the background, and saves them in /var/cache/PackageKit/metadata/<repo>/packages (maybe based on drpms)

I didn't find an option to disable this behavior, that may be undesirable in some cases :

  - when access to the network is expensive (eg prepaid access) and/or limited to a fixed amount of data, over mobile broadband for example. In such case, the user may want to choose for which usage he prefers to spend his network access.

  - when available bandwidth is slow already, the user may prefer to keep the full bandwidth available for interactive usage, instead of for background network activity, that silently reduces even more his available bandwidth.

Ideally, if everything could work automatically, the ModemManager/NetworkManager should provide a hint to other apps, if one of the connections that contribute to the default route, should be considered as "rare", and used with economy in mind. And PackageKit could use this hint to download updates more-or-less aggressively.
Comment 1 bbk 2016-03-02 14:00:45 UTC
Could this be a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=80053 ?
Comment 2 Fabrice Bellet 2016-03-02 21:30:19 UTC
I think it's a different case. However NetworkManager added a "metered" property to connections in Fedora 23, that can be enabled with the cli. I'm not sure if this information is taken into account in packagekit?
Comment 3 Richard Hughes 2016-03-03 09:33:06 UTC
In Fedora 24 we use the NM metered property.
Comment 4 Marcin Zajaczkowski 2017-10-16 23:11:59 UTC
Partially related to bug 91572.
Comment 5 Richard Hughes 2018-08-21 15:53:02 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.