Bug 91637 - Offline upgrades exit with error "Failed to find <package>"
Summary: Offline upgrades exit with error "Failed to find <package>"
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-14 14:32 UTC by Kamil Páral
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
packagekit.service output before rebooting into offline update mode (243.13 KB, text/plain)
2015-08-14 14:33 UTC, Kamil Páral
Details
full journal before rebooting into offline update mode (523.76 KB, text/plain)
2015-08-14 14:33 UTC, Kamil Páral
Details
journal from offline update (155.37 KB, text/plain)
2015-08-14 14:34 UTC, Kamil Páral
Details
rpm -qa (48.11 KB, text/plain)
2015-08-14 14:34 UTC, Kamil Páral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kamil Páral 2015-08-14 14:32:02 UTC
What I did:
1. booted Fedora 22 machine
2. opened gnome-software, went to Updates tab and checked that there are some updates ready
3. powered off the machine, while ticking the checkbox "Install pending updates" in GNOME
4. the machine rebooted into offline updates mode, and immediately exited with error:

Aug 03 07:45:53 medusa packagekitd[587]: 07:45:53        PackageKit        emitting error-code package-not-found, 'Failed to find abrt;2.6.1-1.fc22;x86_64;updates'
Aug 03 07:45:53 medusa pk-offline-update[570]: percentage 10%
Aug 03 07:45:53 medusa pk-offline-update[570]: status finished
Aug 03 07:45:53 medusa PackageKit[587]: update-packages transaction /169_abaecaac from uid 0 finished with failed after 5274ms
Aug 03 07:45:53 medusa packagekitd[587]: 07:45:53        PackageKit        backend was running for 5274 ms
Aug 03 07:45:53 medusa packagekitd[587]: 07:45:53        PackageKit        emitting finished 'failed', 5274
Aug 03 07:45:53 medusa packagekitd[587]: 07:45:53        PackageKit        transaction now finished
Aug 03 07:45:53 medusa packagekitd[587]: 07:45:53        PackageKit        1 transactions in list, 0 committed but not finished
Aug 03 07:45:53 medusa pk-offline-update[570]: writing failed results
Aug 03 07:45:53 medusa pk-offline-update[570]: failed to update system: Failed to find abrt;2.6.1-1.fc22;x86_64;updates
Aug 03 07:45:59 medusa packagekitd[587]: 07:45:59        PackageKit        transaction /169_abaecaac completed, removing
Aug 03 07:45:59 medusa packagekitd[587]: 07:45:59        PackageKit        emitting destroy /169_abaecaac
Aug 03 07:46:04 medusa pk-offline-update[570]: rebooting


I've seen this multiple times, but this is the first time I had enabled PackageKit debug output by default, so I can supply better logs.

Usually if I reboot, go to gnome-software, and force refresh of updates, the problem is gone.

It seems like there is some race condition and either PK reports updates are ready when they are not, or maybe two different programs access that location and somehow overwrites files to each other. No idea. Pretty much default F22 installation.

PackageKit-1.0.6-6.fc22.x86_64
libhif-0.2.0-4.fc22.x86_64
librepo-1.7.16-1.fc22.x86_64
gnome-software-3.16.4-1.fc22.x86_64
gnome-shell-3.16.3-1.fc22.x86_64
rpm-4.12.0.1-12.fc22.x86_64
dnf-1.0.1-2.fc22.noarch
Comment 1 Kamil Páral 2015-08-14 14:33:21 UTC
Created attachment 117684 [details]
packagekit.service output before rebooting into offline update mode
Comment 2 Kamil Páral 2015-08-14 14:33:53 UTC
Created attachment 117685 [details]
full journal before rebooting into offline update mode
Comment 3 Kamil Páral 2015-08-14 14:34:20 UTC
Created attachment 117686 [details]
journal from offline update
Comment 4 Kamil Páral 2015-08-14 14:34:36 UTC
Created attachment 117687 [details]
rpm -qa
Comment 5 Richard Hughes 2018-08-21 15:52:35 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.