Bug 91650 - [snb blorp] GPU HANG in Terraria
Summary: [snb blorp] GPU HANG in Terraria
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-15 18:31 UTC by Nelson A. de Oliveira
Modified: 2019-09-25 18:54 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
full dmesg (16.17 KB, text/plain)
2015-08-15 18:31 UTC, Nelson A. de Oliveira
Details
/sys/class/drm/card0/error output (260.42 KB, application/x-bzip)
2015-08-15 18:32 UTC, Nelson A. de Oliveira
Details
glxinfo output (20.26 KB, text/plain)
2015-08-17 10:24 UTC, Nelson A. de Oliveira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nelson A. de Oliveira 2015-08-15 18:31:51 UTC
Created attachment 117710 [details]
full dmesg

Was trying to play Terraria and saw this:

[ 5959.279079] [drm] stuck on render ring
[ 5959.279509] [drm] GPU HANG: ecode 6:0:0x84feeffc, in Terraria.bin.x8 [6369], reason: Ring hung, action: reset
[ 5959.279510] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 5959.279511] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 5959.279512] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 5959.279512] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 5959.279513] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 5959.287045] drm/i915: Resetting chip after gpu hang
[ 5965.320467] [drm] stuck on render ring
[ 5965.320916] [drm] GPU HANG: ecode 6:0:0x84fefffc, in Terraria.bin.x8 [6369], reason: Ring hung, action: reset
[ 5965.328419] drm/i915: Resetting chip after gpu hang
[ 5971.241939] [drm] stuck on render ring
[ 5971.242571] [drm] GPU HANG: ecode 6:0:0x84fefffc, in steam [1348], reason: Ring hung, action: reset
[ 5971.249927] drm/i915: Resetting chip after gpu hang
[ 5977.283335] [drm] stuck on render ring
[ 5977.283942] [drm] GPU HANG: ecode 6:0:0x84fefffc, in steam [1348], reason: Ring hung, action: reset
[ 5977.291271] drm/i915: Resetting chip after gpu hang
[ 5984.026748] CIPCServer::Thr[1384]: segfault at c ip 00000000efc2d9be sp 00000000eec39910 error 4 in steamclient.so[ef15a000+10e1000]

dmseg and /sys/class/drm/card0/error are attached
Comment 1 Nelson A. de Oliveira 2015-08-15 18:32:21 UTC
Created attachment 117711 [details]
/sys/class/drm/card0/error output
Comment 2 Tapani Pälli 2015-08-17 09:55:18 UTC
Could you attach output of glxinfo on your system? I can try to reproduce this if I have similar system.
Comment 3 Nelson A. de Oliveira 2015-08-17 10:24:28 UTC
Created attachment 117729 [details]
glxinfo output

Sure, attached.
Comment 4 Tapani Pälli 2015-09-18 10:50:26 UTC
I've played a bit on my SNB but cannot reproduce hang. Does it consistently hang for you? Was the game in some certain state or just in middle of regular scene?
Comment 5 ulrik.sverdrup 2015-09-24 00:08:52 UTC
Due to my experience with #91762, I'd recommend trying linux 4.1.8 and see if that fixes it.
Comment 6 Matt Turner 2017-03-22 03:16:07 UTC
Please reopen if you can still reproduce with Mesa 17.0.
Comment 7 Danylo 2018-06-14 15:19:16 UTC
I wasn't able to reproduce the issue on:
Mesa: 18.1.1, 10.3, 10.6.4 - there were graphic artifacts on old Mesas but no hangs,
Kernel: 4.14
Sandy Bridge cpu
As stated in before it seems it was a kernel related issue and resolved long ago.
Comment 8 GitLab Migration User 2019-09-25 18:54:23 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1489.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.