Bug 91743 - Desktop corruption when changing monitor config
Summary: Desktop corruption when changing monitor config
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-24 14:15 UTC by Sebastien Bacher
Modified: 2015-09-17 12:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Bacher 2015-08-24 14:15:14 UTC
The bug has been reported on https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1421575

"Thinkpad X220 running vivid up to date.

Usually sits in docking station with external monitor.

Today I ran the laptop outside the docking station, and plugged it into the dock while running (which worked fine forever on utopic) but today it now freaks out.

I deleted ~/.config/monitors.xml to reset my display config

I restarted and logged in with both monitors active.

As soon as I change the display config doing the display corrupts, flickers and becomes unusable.

Here's a photo:- http://imgur.com/80LcmgV

GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
"


xorg log, https://launchpadlibrarian.net/197510967/XorgLog.txt
Comment 1 Sebastien Bacher 2015-08-24 14:19:18 UTC
Similar corruption happens using an inspiron 11 3138 config on wily, when connecting a projector with hdmi the screen corrupts and things don't recover until the session is restarted

the syslog has those warnings
"kernel: [ 2006.138268] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment"
Comment 2 Sebastien Bacher 2015-08-24 14:22:00 UTC
the inspiron video card is

00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0a) (prog-if 00 [VGA controller])
Comment 3 Sebastien Bacher 2015-09-17 12:52:18 UTC
video showing the issue on https://www.youtube.com/watch?v=ElXAyX93Uqw


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.