Bug 91764 - [drm] GPU HANG: ecode 8:0:0x00201001, reason: Ring hung, action: reset
Summary: [drm] GPU HANG: ecode 8:0:0x00201001, reason: Ring hung, action: reset
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-26 17:33 UTC by siflfran
Modified: 2017-07-24 22:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
crash log (2.66 MB, text/plain)
2015-08-26 17:33 UTC, siflfran
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description siflfran 2015-08-26 17:33:42 UTC
Created attachment 117927 [details]
crash log

I get the following when load the i915 module on a broadwell-u:

[  891.121322] [drm] Initialized drm 1.1.0 20060810
[  891.127056] [drm] Memory usable by graphics device = 4096M
[  891.127151] [drm] VT-d active for gfx access
[  891.127251] [drm] Replacing VGA console driver
[  891.127957] Console: switching to colour dummy device 80x25
[  891.134284] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[  891.134290] [drm] Driver supports precise vblank timestamp query.
[  891.134435] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[  891.147350] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[  891.147690] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input7
[  891.147803] [drm] Initialized i915 1.6.0 20150327 for 0000:00:02.0 on minor 0
[  891.185303] fbcon: inteldrmfb (fb0) is primary device
[  891.313813] Console: switching to colour frame buffer device 240x67
[  891.318478] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[  891.318504] i915 0000:00:02.0: registered panic notifier
[  899.180411] [drm] stuck on render ring
[  899.181241] [drm] GPU HANG: ecode 8:0:0x00201001, reason: Ring hung, action: reset
[  899.181272] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  899.181307] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  899.181341] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  899.181376] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  899.181423] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  899.183561] drm/i915: Resetting chip after gpu hang
[  905.179524] [drm] stuck on render ring
[  905.180348] [drm] GPU HANG: ecode 8:0:0x00201001, reason: Ring hung, action: reset
[  905.180435] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[  905.182602] drm/i915: Resetting chip after gpu hang
Comment 1 Chris Wilson 2015-08-27 15:14:16 UTC
The error seems consistent with the other iommu-related snafu.

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.