Bug 91893 - R100: GPU lockup: EQ overflowing
Summary: R100: GPU lockup: EQ overflowing
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: 11.0
Hardware: PowerPC Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-06 10:33 UTC by macro
Modified: 2019-09-18 18:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Full dmesg (47.95 KB, text/plain)
2015-09-06 10:43 UTC, macro
Details
Full Xorg.0.log (37.09 KB, text/plain)
2015-09-06 10:43 UTC, macro
Details
radeontool registers dump before lockup (19.66 KB, text/plain)
2015-09-28 09:25 UTC, macro
Details
radeontool registers dump after lockup (19.75 KB, text/plain)
2015-09-28 09:25 UTC, macro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description macro 2015-09-06 10:33:33 UTC
The following GPU lockup occurs consistently soon after starting Dillo (an fltk-based lightweight web browser) compiled without Cairo support.

I am happy to provide any additional information or diagnose further as directed.

"ATI Radeon 7500 QW (AGP/PCI)" (ChipID = 0x5157)

Linux cube 4.1.6-gentoo #2 Sat Aug 29 23:38:46 AEST 2015 ppc 7400, altivec supported PowerMac5,1 GNU/Linux

mesa-11.0.0_rc1

dmesg
...
[ 2561.090198] radeon 0000:00:10.0: ring 0 stalled for more than 10000msec
[ 2561.090226] radeon 0000:00:10.0: GPU lockup (current fence id 0x0000000000000125 last fence id 0x0000000000000126 on ring 0)
[ 2561.095953] radeon 0000:00:10.0: Saved 27 dwords of commands on ring 0.
[ 2561.095969] radeon 0000:00:10.0: GPU reset succeeded, trying to resume
[ 2561.096012] [drm] PCI GART of 32M enabled (table at 0x000000002EE08000).
[ 2561.096026] radeon 0000:00:10.0: WB disabled
[ 2561.096044] radeon 0000:00:10.0: fence driver on ring 0 use gpu addr 0x0000000096000000 and cpu addr 0xeed95000
[ 2561.096140] [drm] radeon: ring at 0x0000000096001000
[ 2561.243896] [drm:r100_ring_test] *ERROR* radeon: ring test failed (scratch(0x15E8)=0xCAFEDEAD)
[ 2561.243908] [drm:r100_cp_init] *ERROR* radeon: cp isn't working (-22).
[ 2561.243920] radeon 0000:00:10.0: failed initializing CP (-22).
...

Xorg.0.log
...
(EE) [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x58) [0x101ccefc]
(EE) 1: /usr/bin/X (mieqEnqueue+0x120) [0x101abe78]
(EE) 2: /usr/bin/X (0x10000000+0x48414) [0x10048414]
(EE) 3: /usr/bin/X (QueuePointerEvents+0x68) [0x1004b56c]
(EE) 4: /usr/bin/X (xf86PostMotionEventM+0x340) [0x1008ecd4]
(EE) 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x50e4) [0xe9ac0e4]
(EE) 6: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x5a24) [0xe9aca24]
(EE) 7: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x5d80) [0xe9acd80]
(EE) 8: /usr/bin/X (0x10000000+0x7adec) [0x1007adec]
(EE) 9: /usr/bin/X (0x10000000+0xad47c) [0x100ad47c]
(EE) 10: linux-vdso32.so.1 (__kernel_sigtramp32+0x0) [0x100364]
(EE) 11: /lib/libc.so.6 (ioctl+0xe0) [0xfa3ce00]
(EE) 12: ?? [0x0]
(EE) 13: /usr/lib/libdrm.so.2 (drmIoctl+0x50) [0xfd436ac]
(EE) 14: /usr/lib/libdrm.so.2 (drmCommandWrite+0x38) [0xfd46e3c]
(EE) 15: /usr/lib/libdrm_radeon.so.1 (0xf01c000+0x1650) [0xf01d650]
(EE) 16: /usr/lib/libdrm_radeon.so.1 (0xf01c000+0x1788) [0xf01d788]
(EE) 17: /usr/lib/libdrm_radeon.so.1 (radeon_bo_map+0x20) [0xf01f22c]
(EE) 18: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xf04d000+0x30ab0) [0xf07dab0]
(EE) 19: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x6168) [0xefb0168]
(EE) 20: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x63a0) [0xefb03a0]
(EE) 21: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x90c8) [0xefb30c8]
(EE) 22: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x4bf4) [0xefaebf4]
(EE) 23: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x12ea8) [0xefbcea8]
(EE) 24: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x9e88) [0xefb3e88]
(EE) 25: /usr/bin/X (0x10000000+0x146dfc) [0x10146dfc]
(EE) 26: /usr/bin/X (0x10000000+0x2bacc) [0x1002bacc]
(EE) 27: /usr/bin/X (0x10000000+0x30254) [0x10030254]
(EE) 28: /usr/bin/X (0x10000000+0x349c0) [0x100349c0]
(EE) 29: /usr/bin/X (0x10000000+0x1c2b8) [0x1001c2b8]
(EE) 30: /lib/libc.so.6 (0xf956000+0x21938) [0xf977938]
(EE) 31: /lib/libc.so.6 (0xf956000+0x21ad8) [0xf977ad8]
(EE)
(EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
(EE) [mi] mieq is *NOT* the cause.  It is a victim.
(EE) [mi] EQ overflow continuing.  100 events have been dropped.
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x58) [0x101ccefc]
(EE) 1: /usr/bin/X (mieqEnqueue+0x190) [0x101abee8]
(EE) 2: /usr/bin/X (0x10000000+0x48414) [0x10048414]
(EE) 3: /usr/bin/X (QueuePointerEvents+0x68) [0x1004b56c]
(EE) 4: /usr/bin/X (xf86PostMotionEventM+0x340) [0x1008ecd4]
(EE) 5: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x50e4) [0xe9ac0e4]
(EE) 6: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x5a24) [0xe9aca24]
(EE) 7: /usr/lib/xorg/modules/input/evdev_drv.so (0xe9a7000+0x5d80) [0xe9acd80]
(EE) 8: /usr/bin/X (0x10000000+0x7adec) [0x1007adec]
(EE) 9: /usr/bin/X (0x10000000+0xad47c) [0x100ad47c]
(EE) 10: linux-vdso32.so.1 (__kernel_sigtramp32+0x0) [0x100364]
(EE) 11: /lib/libc.so.6 (ioctl+0xe0) [0xfa3ce00]
(EE) 12: ?? [0x0]
(EE) 13: /usr/lib/libdrm.so.2 (drmIoctl+0x50) [0xfd436ac]
(EE) 14: /usr/lib/libdrm.so.2 (drmCommandWrite+0x38) [0xfd46e3c]
(EE) 15: /usr/lib/libdrm_radeon.so.1 (0xf01c000+0x1650) [0xf01d650]
(EE) 16: /usr/lib/libdrm_radeon.so.1 (0xf01c000+0x1788) [0xf01d788]
(EE) 17: /usr/lib/libdrm_radeon.so.1 (radeon_bo_map+0x20) [0xf01f22c]
(EE) 18: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xf04d000+0x30ab0) [0xf07dab0]
(EE) 19: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x6168) [0xefb0168]
(EE) 20: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x63a0) [0xefb03a0]
(EE) 21: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x90c8) [0xefb30c8]
(EE) 22: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x4bf4) [0xefaebf4]
(EE) 23: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x12ea8) [0xefbcea8]
(EE) 24: /usr/lib/xorg/modules/libexa.so (0xefaa000+0x9e88) [0xefb3e88]
(EE) 25: /usr/bin/X (0x10000000+0x146dfc) [0x10146dfc]
(EE) 26: /usr/bin/X (0x10000000+0x2bacc) [0x1002bacc]
(EE) 27: /usr/bin/X (0x10000000+0x30254) [0x10030254]
(EE) 28: /usr/bin/X (0x10000000+0x349c0) [0x100349c0]
(EE) 29: /usr/bin/X (0x10000000+0x1c2b8) [0x1001c2b8]
(EE) 30: /lib/libc.so.6 (0xf956000+0x21938) [0xf977938]
(EE) 31: /lib/libc.so.6 (0xf956000+0x21ad8) [0xf977ad8]
Comment 1 macro 2015-09-06 10:43:10 UTC
Created attachment 118097 [details]
Full dmesg
Comment 2 macro 2015-09-06 10:43:27 UTC
Created attachment 118098 [details]
Full Xorg.0.log
Comment 3 macro 2015-09-28 09:25:06 UTC
Created attachment 118476 [details]
radeontool registers dump before lockup
Comment 4 macro 2015-09-28 09:25:34 UTC
Created attachment 118477 [details]
radeontool registers dump after lockup
Comment 5 macro 2015-09-28 09:39:36 UTC
Kernel arguments:

radeon.no_wb=1
radeon.dynclks=0
radeon.agpmode=-1
radeon.gartsize=32
radeon.msi=0
radeon.dpm=0
radeon.aspm=0
radeon.runpm=0
radeon.hard_reset=1
radeon.use_pflipirq=0
radeon.bapm=0

One or more (not sure exactly which) are required in order for X to start without hanging the machine.
Comment 6 GitLab Migration User 2019-09-18 18:40:49 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/287.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.