Bug 9192 - video mode set too high for ATI ES1000
Summary: video mode set too high for ATI ES1000
Status: RESOLVED DUPLICATE of bug 5766
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-29 00:42 UTC by LisaWu
Modified: 2007-08-31 07:58 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Change the empirical value back, limit pixel clock to meet memory bandwidth limits (805 bytes, patch)
2006-11-29 02:10 UTC, LisaWu
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description LisaWu 2006-11-29 00:42:47 UTC
the latest git code of radeon driver will set big modes that beyond ATI 
ES1000's capability.
resolution 1280x1024@75hz at32bpp as well as 1600x1200@85hz at 16bpp are not 
pruned by the driver.these modes are beyond ES1000 can support at 200MHZ and 
will lead to uncertain status.

Acoording to chip spec.At 200MHZ,ES1000 cannot handle modes that higher than:

8bpp 1920x1440@60hz
16bpp 1600x1200@75hz
32bpp 1280x1024@60hz
please refer to bug #5766 to get detailed information:
https://bugs.freedesktop.org/show_bug.cgi?id=5766

the root cause of this bug is the driver enlarged the pixel clock range of 
es1000 by changing the empirical pixel clock max value in radeon driver, thus 
add some big modes to the valid mode list. 

I suggest change back the original pixel clock range of ES1000. 
patch will be attached soon.
Comment 1 LisaWu 2006-11-29 02:10:48 UTC
Created attachment 7917 [details] [review]
Change the empirical value back, limit pixel clock to meet memory bandwidth limits
Comment 2 Michel Dänzer 2006-11-29 02:17:50 UTC
Yes, I pointed this out on several occasions. Henry, do you object to this change?
Comment 3 Daniel Stone 2007-02-27 01:34:53 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 4 Alex Deucher 2007-08-31 07:58:48 UTC

*** This bug has been marked as a duplicate of bug 5766 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.