Bug 91927 - [SKL] [regression] piglit compressed textures tests fail with kernel upgrade
Summary: [SKL] [regression] piglit compressed textures tests fail with kernel upgrade
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nanley Chery
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-08 23:31 UTC by Mark Janes
Modified: 2015-12-17 18:55 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-09-08 23:31:36 UTC
When the SKL kernels were upgraded, the following piglit tests regressed:

 piglit.spec.ext_texture_compression_s3tc.getteximage-targets cube_array s3tc
 piglit.spec.arb_get_texture_sub_image.arb_get_texture_sub_image-getcompressed
 piglit.spec.arb_texture_cube_map_array.fbo-generatemipmap-cubemap array s3tc_dxt1

Failing kernel version:
38090ed drm-intel-nightly: 2015y-09m-02d-15h-24m-23s UTC integration manifest

The passing kernel version was a drm nightly 4.1.0 kernel pulled around June 7.
Comment 1 Ben Widawsky 2015-10-23 15:07:01 UTC
Mark, why did you assign this to Ian if the kernel update made the failure happen?
Comment 2 Mark Janes 2015-10-23 16:34:04 UTC
Ian gets bugs by default.  If I know who to assign a bug to, then I assign it directly.  Who are the candidates to get this bug?
Comment 3 Ben Widawsky 2015-10-23 16:36:35 UTC
On Fri, Oct 23, 2015 at 04:34:04PM +0000, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=91927
> 
> --- Comment #2 from Mark Janes <mark.a.janes@intel.com> ---
> Ian gets bugs by default.  If I know who to assign a bug to, then I assign it
> directly.  Who are the candidates to get this bug?
> 

Kernel bugs should be assigned to Intel GFX Bugs mailing list by default.
Comment 4 Nanley Chery 2015-10-28 00:30:49 UTC
(In reply to Mark Janes from comment #0)
> When the SKL kernels were upgraded, the following piglit tests regressed:
> 
>  piglit.spec.ext_texture_compression_s3tc.getteximage-targets cube_array s3tc
>  piglit.spec.arb_get_texture_sub_image.arb_get_texture_sub_image-
> getcompressed
>  piglit.spec.arb_texture_cube_map_array.fbo-generatemipmap-cubemap array
> s3tc_dxt1
> 
> Failing kernel version:
> 38090ed drm-intel-nightly: 2015y-09m-02d-15h-24m-23s UTC integration manifest
> 
> The passing kernel version was a drm nightly 4.1.0 kernel pulled around June
> 7.

Was mesa updated as well? Neil has pointed out that some of the ASTC patches may have caused these regressions.
Comment 5 Mark Janes 2015-10-28 16:23:30 UTC
When I wrote this bug up, I was upgrading SKL kernels and attributed the failure to that change.  However, now that I am testing SKL on a regular basis, I can see that these tests regressed in Mesa since 11.0.

I bisected the test, and found that it regressed when ASTC was enabled for SKL:

Author:     Nanley Chery <nanley.g.chery@intel.com>
AuthorDate: Tue May 19 12:28:20 2015 -0700
Commit:     Nanley Chery <nanley.g.chery@intel.com>
CommitDate: Mon Aug 31 17:29:36 2015 -0700

    i965: advertise ASTC support for Skylake
    
    v2: remove OES ASTC extension reference.
    
    Reviewed-by: Anuj Phogat <anuj.phogat@gmail.com>
    Signed-off-by: Nanley Chery <nanley.g.chery@intel.com>
Comment 6 Nanley Chery 2015-10-28 16:51:05 UTC
I've submitted a patch to the mailing list which fixes this issue:

http://lists.freedesktop.org/archives/mesa-dev/2015-October/098524.html
Comment 7 Neil Roberts 2015-12-17 18:35:03 UTC
I assume this bug is now fixed because these tests are passing and Nanley's patch has been merged:

http://cgit.freedesktop.org/mesa/mesa/commit/?id=d1212abf505a468c9947a66dbf


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.