Bug 91994 - Samsung U28D590D Monitor does not wake up after power saving mode
Summary: Samsung U28D590D Monitor does not wake up after power saving mode
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-13 16:11 UTC by Adam Flott
Modified: 2015-11-19 20:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
system information (3.48 KB, text/plain)
2015-09-13 16:11 UTC, Adam Flott
no flags Details
lscpi -vvv output (34.51 KB, text/plain)
2015-09-13 16:11 UTC, Adam Flott
no flags Details
Xorg.0.log (39.67 KB, text/plain)
2015-09-13 16:12 UTC, Adam Flott
no flags Details
dmesg (69.68 KB, text/plain)
2015-09-13 16:12 UTC, Adam Flott
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Flott 2015-09-13 16:11:30 UTC
Created attachment 118244 [details]
system information

I've tried a number of desktop environments and window managers and they all behave the same. When the power saving mode is activated, any attempt to wake up the monitor with a keyboard or mouse results in a blank screen, waits a few seconds, and then goes back to power saving mode.

The monitor is: http://www.samsung.com/us/support/owners/product/LU28D590DS/ZA

I have to resort to using another computer to ssh in and running a combo of "xset dpms force on" and "xset dpms force off" until the display comes online.

This issue has been present since I bought the monitor fall 2014 and tried with a number of xorg / gpu / kernel upgrades. However, this issue is not present on Windows 8 / 10.
Comment 1 Adam Flott 2015-09-13 16:11:48 UTC
Created attachment 118245 [details]
lscpi -vvv output
Comment 2 Adam Flott 2015-09-13 16:12:03 UTC
Created attachment 118246 [details]
Xorg.0.log
Comment 3 Adam Flott 2015-09-13 16:12:14 UTC
Created attachment 118247 [details]
dmesg
Comment 4 Adam Flott 2015-11-19 20:33:30 UTC
This looks to have been fixed from 4.2->4.3 xf86-video-ati 7.5->7.6 and I thank you immensely. My sanity has been restored.
Comment 5 Adam Flott 2015-11-19 20:33:46 UTC
(In reply to Adam Flott from comment #4)
> This looks to have been fixed from 4.2->4.3 xf86-video-ati 7.5->7.6 and I
> thank you immensely. My sanity has been restored.

That is Linux kernel 4.2->4.3


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.