Bug 92025 - XRANDR command not added a new force resolutions
Summary: XRANDR command not added a new force resolutions
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xrandr (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium critical
Assignee: Keith Packard
QA Contact: Xorg Project Team
URL: http://patchwork.freedesktop.org/patc...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 17:10 UTC by rmbeer
Modified: 2018-08-10 20:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rmbeer 2015-09-16 17:10:45 UTC
i have this resolution of the accept in the same monitor that i use:

  320x240 (0x???) 12.587MHz -HSync -VSync DoubleScan
        h: width   320 start  328 end  376 total  400 skew    0 clock  31.47KHz
        v: height  240 start  245 end  246 total  262           clock  60.05Hz

I need added this resolution with xrandr command:

xrandr --newmode "320x240" 12.587 320 328 376 400  240 245 246 262  "doublescan -hsync -vsync"
xrandr --newmode "320x240" 12.587 320 328 376 400  240 245 246 262  doublescan -hsync -vsync
xrandr --newmode "320x240" 12.587 320 328 376 400  240 245 246 262  DoubleScan -HSync -VSync
xrandr --newmode "320x240" 12.587 320 328 376 400  240 245 246 262  -HSync -VSync DoubleScan
(all testing other variants)

But only getting this result: (for --newmode)

  320x240 (0x???) 12.587MHz
        h: width   320 start  328 end  376 total  400 skew    0 clock  31.47KHz
        v: height  240 start  245 end  246 total  262           clock 120.10Hz

And not accept the added the mode in the list: (for --addmode)

$ xrandr --addmode ??? 320x240
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  29
  Current serial number in output stream:  30

??? = (for any card of list/testing with all)

I Can't added the new resolution.


Note: For each new test with --newmode i use --rmmode for clean the temp list.
Comment 1 rmbeer 2015-09-16 17:12:25 UTC
NOTE: i testing the variants of "-HSync -VSync DoubleScan" why this flags not added in the list of temp resolutions...
Comment 2 Chris Wilson 2015-09-17 09:43:16 UTC
The correct version is 

xrandr --newmode "320x240" 12.587 320 328 376 400  240 245 246 262  DoubleScan -HSync -VSync

The issue is just that the flags weren't being pretty printed on the temporary modes.

http://patchwork.freedesktop.org/patch/59755/
Comment 3 rmbeer 2015-09-18 17:31:07 UTC
Chris Wilson
Thank for answer. I change the source code by the patch. And now show this result:

  320x240 (0x???)   12.6MHz -HSync -VSync DoubleScan
        h: width   320 start  328 end  376 total  400 skew    0 clock   31.5KHz
        v: height  240 start  245 end  246 total  262           clock  120.1Hz

Is the same of the first detect of resolution:

  320x240 (0x???) 12.587MHz -HSync -VSync DoubleScan
        h: width   320 start  328 end  376 total  400 skew    0 clock  31.47KHz
        v: height  240 start  245 end  246 total  262           clock  60.05Hz

But always result in this error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  29
  Current serial number in output stream:  30

I reading in the source code and change/show all values of variables, have that in two variables for libxrandr/XrrMode.c (XRRAddOutputMode function):

req->output = is the first of the list of resolution of xrandr with -1.
req->mode = is the mode of 320x240 created with --newmode.

example:

0x204 - 640x480 +
0x205 - 800x600
0x206 - 1024x768*
0x207 - 1280x1024
0x208 - 320x240 (created with --newmode)

output=0x203
mode=0x208

I cann't testing or change the xorg driver for view most datas from variables.

The error output where read XSync() function.
Comment 4 GitLab Migration User 2018-08-10 20:34:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/app/xrandr/issues/25.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.