Bug 92066 - [ILK,G45,regression] New assertion on BRW_MAX_MRF breaks ilk and g45
Summary: [ILK,G45,regression] New assertion on BRW_MAX_MRF breaks ilk and g45
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Iago Toral
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-21 13:43 UTC by Mark Janes
Modified: 2015-09-21 14:47 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2015-09-21 13:43:37 UTC
the series d48ac93066190077510d635e71631b6574261d08 - 5d23ce2f15bda866990750b49d7860144dff2e68 generates about 8k assertions in piglit on g45 and ilk:

src/mesa/drivers/dri/i965/brw_eu_emit.c:150: brw_set_dest: Assertion `dest.nr < (devinfo->gen == 6 ? 24 : 16)' failed.

I'm disabling testing on g45 and ilk until this bug is resolved.
Comment 1 Kenneth Graunke 2015-09-21 14:47:28 UTC
Fixed on master with:

commit c1070550c289d48ef389aeb8c564d1abd1123ad1
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Mon Sep 21 07:42:27 2015 -0700

    i965: Fix MRF register number assertions for compr4.
    
    compr4 is represented by setting the high bit on the MRF number.
    We need to mask it out before sanity checking the register number.
    
    Fixes ~8000 assert fails on Ironlake and G45.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=92066
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>

I decided just to push the patch because it was a simple mistake with an obvious fix, and I'd rather not leave every GL program on G45/ILK broken longer than I have to :)


bug/show.html.tmpl processed on Mar 25, 2017 at 09:36:42.
(provided by the Example extension).